Ask / Submit
2

Synchronisation and Horde

asked 2014-01-13 14:59:19 +0300

elakim gravatar image

updated 2014-01-27 19:27:45 +0300

Hi! In our Uni, we have a test installation of the Horde Webmail Edition collaboration suite. When I first got my Jolla, I was able to sync my calendar with that (but nothing else, alas - my Nokia X3-02 could sync notes and todo lists, too). With the current release, Maadajävri, I'm unable to create the required "Exchange" account: the credentials aren't accepted, nothing is synced. Anyone else with similar trouble?

edit retag flag offensive close delete

Comments

What error do you see ? Credentials not accepted or problem with certificates ? If your server has self-signed certificates you need to select the option "Accept all SSL certificates" in the account manual setup.

VDVsx ( 2014-01-14 10:20:00 +0300 )edit

"Problem with checking credentials" - I wonder if I'm entering my account name in wrong format or something. Tried "username" and "\username" and "username@domain", nothing works. And I didn't write down the settings I had working in the previous SailfishOS release :(

elakim ( 2014-01-14 10:45:20 +0300 )edit

Don't you have a help page where you can check the settings ? Most common username these days is full email address, but several variations are supported: username, username@domain, domain\username, ....

VDVsx ( 2014-01-14 16:33:33 +0300 )edit

It should be plain username, but that doesn't work. Neither does anything else I can think of. And the server logs don't even show the incoming connection from my Jolla. (If I try to connect with openssl s_client, that gets logged, so not a network problem. Next I'm going to install tcpdump...)

elakim ( 2014-01-14 16:59:48 +0300 )edit

Did you tried to select "Accept all SSL certiicates" ?

VDVsx ( 2014-01-14 21:19:44 +0300 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2014-01-15 17:28:24 +0300

netzvieh gravatar image

updated 2014-01-15 17:30:56 +0300

To get Exchange working with my companys horde instance I have the following settings:

  • Email Address -> username@company.de
  • Username -> username
  • Password -> my password
  • Server Domain -> empty
  • Server Address -> horde server
  • Server Port -> SSL Port

Maybe you specified a domain instead of the server address?

edit flag offensive delete publish link more

Comments

but why do I have to install microsoft exchange, when I actually only want to sync the calendar with my linux NAS??? Is it because of the activesync package?

aimless ( 2014-01-15 18:00:45 +0300 )edit

@aimless "Microsoft Exchange" just adds support for Active Sync, which is a Microsoft technology and Exchange is the best known Service offering it. Or does the installed package contain anything else? Haven't looked into it yet. If your NAS supports CalDAV you could switch to that, when it's properly supported on Sailfish.

netzvieh ( 2014-01-15 20:59:23 +0300 )edit

Ok, thank you! But, I don't really know how to configure neither M-Exchange nor CalDav. Is it necessary to have an e-mail address, if I only wanna sync the calendar? How should the server address look like, if I wanna sync with my NAS in a priv. network? s.th. like \192.168.x.x\path\to\x.ics-file?

aimless ( 2014-01-20 21:01:10 +0300 )edit

Further, CalDAV is only the protocol, do I therefore need an additional CalDAV client? Or is it already supported of jollas calendar?

aimless ( 2014-01-20 21:04:28 +0300 )edit
Login/Signup to Answer

Question tools

Follow
4 followers

Stats

Asked: 2014-01-13 14:59:19 +0300

Seen: 582 times

Last updated: Jan 15 '14