Ask / Submit
7

Jolla C has strange behavior with WLAN and mobile data connection

asked 2016-09-08 15:24:08 +0200

Wildchild gravatar image

updated 2016-09-13 17:38:52 +0200

Federico gravatar image

My Jolla C shows a strange behavior when I´m on my desk at home and connected to Wifi. It has a pretty good signal connection (two to three bars on icon) but unfortunately the phone reconnects from time to time to Wifi again. (The Wifi-Station is in the next room 7 meter far away.)

So for example my screen is on and shows the notification screen. I can see it reconnects in irregular offsets. If the screen is off it goes on and I can see it is reconnecting again.

When I leave the building the phone is struggling between Wifi and mobile data connection. A few meter distance from home most of the time there is no data connection. Wifi nor Mobile Data. It seems the phone can´t decide what connection it should prefer. When I shut off Wifi manually it connects to mobile data and suddenly I get Push Notifications from eg. Twitter or my messengers.

Right now I´m sitting in a day office, connected to Wifi. I receive Push Notifications, no flashing screen, no reconnecting...

How can I figure out how strong really the Wifi connection on my phone is? Why it is always reconnecting? What I knew is the Wifi-Station here at the day office is a very old model, not the newest technology while the one at my home is a newer one.

Any suggestions or same experience? Because I think it isn´t a bug.

EDIT: I am retagging as bug because the answers confirm that it is due to wrong handling of rekeying. I hope this is enough to get it on Jolla's to-do list. --Federico

edit retag flag offensive close delete

Comments

you could try the app "WiFi Analyzer" to see the signal strength

till ( 2016-09-08 15:28:58 +0200 )edit

A how-to is step-by-step instructions on how to do something with a Sailfish device. Your post is a question so I removed the tag.

Welcome to TJC. :)

vattuvarg ( 2016-09-08 15:32:40 +0200 )edit

Broken push notifications have been already reported, for instance in https://together.jolla.com/question/122636/bug-android-messaging-whatsapp-messages-arrive-late/, and this seems related to broken network connections. As far as I know this bug is still present. I personally am still affected. Whatsapp messages, for instance, have wrong timestamps, sometimes even in the future (which is weird).

Federico ( 2016-09-08 15:34:29 +0200 )edit

However, the broken push notification problem is independent of signal strength, afaik it happens on some kind of wifi routers/providers with specific connection timeout settings

till ( 2016-09-08 15:42:02 +0200 )edit

@till That's only a conjecture. The true cause for the bug has never been identified. Actually it has been verified that sending packets at regular intervals doesn't fix the problem, so this suggests that it may not be related to timeouts after all.

Federico ( 2016-09-08 16:13:56 +0200 )edit

1 Answer

Sort by » oldest newest most voted
3

answered 2016-09-13 12:01:34 +0200

cuh7b5 gravatar image

I think I found the solution.

The problem is caused by a setting on the router called "Group Key Renewal Interval" (or "Re-Key Interval"). You can read more on this here: http://www.dslreports.com/forum/r12789455-What-the-heck-is-this-Group-Key-Renewal-thing

Normally Group Key Renewal should not affect the clients associated to the AP but somehow Jolla C is intolerant for this and deauthenticates/disconnects then reconnects on every key renewal.

In most scenarios it seems to be safe to turn off Group Key Renewal or set the renewal period to a long period. To do so you need to configure your wifi router to have it disabled or set a renewal time that is long enough not to disturb you every 10 minutes.

On my openWRT router this is done by adding wpa_group_rekey '0' to the /etc/config/wireless file. See: https://forum.openwrt.org/viewtopic.php?pid=215126 and http://www.zron.fr/tools/projets/freetools/Linux/openwrt/wifi%20disconnects.txt and https://dev.openwrt.org/ticket/10025#comment:29.

On other routers you need to find out yourself how to change the rekey setting.

edit flag offensive delete publish link more

Comments

Thank you very much @cuh7b5 !

I have to read up on this topic. Because my router has no option to set it default or change the time interval.

Wildchild ( 2016-09-13 12:42:11 +0200 )edit
1

Great find! Though I would call it a workaround, not a solution. This fix assumes that one has full admin access to the router, so it does not work in every case. I hope that this bug can be fixed by Jolla using your detailed debugging information.

Federico ( 2016-09-13 17:39:49 +0200 )edit

I agree that this is only a workaround since the error causing this behavior is on the Jolla C side which seems to not follow standard procedures. The solution should be to make the Jolla comply with the standard, not changing the standard behavior itself. The same problem occurs with the Aqua Fish (not surprisingly, as they probably share the same WiFi hardware) as I noticed on my device.

ghling ( 2016-10-23 11:09:13 +0200 )edit
Login/Signup to Answer

Question tools

Follow
3 followers

Stats

Asked: 2016-09-08 15:24:08 +0200

Seen: 353 times

Last updated: Sep 13 '16