We have moved to a new Sailfish OS Forum. Please start new discussions there.

Notification LED not turning on and fails test

asked 2014-01-13 18:31:36 +0300

ottulo gravatar image

updated 2014-01-14 10:06:37 +0300

eric gravatar image

I edited the ini file some time ago to customize the LED patterns and had no problems with it, the edited file worked fine. However, since a couple days ago the LED has not been turning on anymore when it should, for example for charging or when I receive a message.

I have tried the following:

  1. LED test in CSD Tool: Fail, tested before, after and in between all changes
  2. Reboot: LED turns on, white, for a few seconds at the start of booting, then off again; above test fails
  3. Restore original ini, restart mce.service: still fails test, remains off
  4. Manually set the brightness from /sys/class/leds/... : LED turns on as it should

Clearly there is nothing wrong with the hardware as each of the colours works (red, green and blue tested). The ini file I restored is the completely unedited original file that I kept as a backup. Yet somehow the LED won't respond when it should.

Any further debugging ideas or ways to restore the functionality? I'd hate to manually turn on the led every time I get a message...

Edit: Fixed typo.

This is what I have in the folder, bolded file has the edited patterns that I thought may be the problem. I have not touched the other files. Does something look suspicious?

[root@localhost nemo]# cd /etc/mce
[root@localhost mce]# ls -l
total 68
-rw-r--r-- 1 root root 26103 Dec 16 21:28 10mce.ini
-rw-r--r-- 1 root root 1481 Dec 16 21:28 20als-defaults.ini
-rw-r--r-- 1 root root 2041 Jan 7 10:52 20hybris-led.ini
-rw-r--r-- 1 root root 2053 Jan 9 22:44 20hybris-led.ini.error

-rw-r--r-- 1 root root 147 Dec 16 21:28 20mce-radio-states.ini
-rwxr-xr-x 1 root root 808 Dec 13 13:35 30csdpatterns.ini
-rw-r--r-- 1 root root 468 Dec 20 17:31 60-als-jolla.ini
-rw-r--r-- 1 root root 301 Dec 20 17:31 60-doubletap-jolla.ini
-rw-r--r-- 1 root root 49 Dec 20 17:31 60-mce-display-blank-timeout.conf
-rw-r--r-- 1 root root 46 Dec 20 17:31 60-mce-display-brightness.conf
-rw-r--r-- 1 root root 72 Dec 20 17:31 60-mce-possible-display-dim-timeouts.conf
[root@localhost mce]#

edit retag flag offensive close delete



all the files in the dir will be loaded, so check for any extra files, e.g. editor backups there? (I assume mcd was just a typo)

sp3000 ( 2014-01-13 22:53:25 +0300 )edit

@ottulo, have you had any luck getting your led back? I tried and re-tried the fix given by @Mohjive in his answer, but I still get no led notifications, and csd test fails...

ssahla ( 2014-01-19 21:56:33 +0300 )edit

@ssahla Sadly, no. I tried the solutions below, but had no luck. I'm hoping we might get some other hints, as I am not too keen on doing a factory reset.

ottulo ( 2014-01-19 22:12:36 +0300 )edit

@ottulo, me neither. I thought I'll see if the next system update fixes this before resorting to a factory reset.

ssahla ( 2014-01-19 22:18:22 +0300 )edit

Same issue for me as described above. White LED blinking for few seconds while booting. No other LED turns on or is blinking at all afterwards. Solution provided below didn't work. I did not any customizing or editing files on OS Level. For sure it is not a hardware issue. Waiting for next update?

vision ( 2014-01-19 22:55:21 +0300 )edit

1 Answer

Sort by » oldest newest most voted

answered 2014-01-13 23:42:31 +0300

Mohjive gravatar image

updated 2014-01-14 00:27:50 +0300

I noticed the same issue just now. Most probably something since I ran the CSD tests. I removed the executable flag from 30csdpatterns.ini

chmod -x /etc/mce/30csdpatterns.ini

moved it out of the way

mv /etc/mce/30csdpatterns.ini /etc/mce/30csdpatterns.ini.disabled

and then restarted the mce service

systemctl restart mce.service

then I got the led back. Don't know which of the actions that were needed. Now that I try to roll back any of the changes the led still works even when the executable bit is set and the 30csdpatterns.ini file has its original name. All my action done in devel-su mode.

edit flag offensive delete publish link more


I also have the same issue, after editing 20hybris-led.ini to customize led behavior. I tried to repeat your steps. But with sysctl I get

error: "restart" is an unknown key
error: "mce.service" is an unknown key

Can you tell me why this is? (I'm not good with this stuff.)

ssahla ( 2014-01-14 00:25:15 +0300 )edit

Typo by me, sorry. It should be

systemctl restart mce.service

I've updated the answer as well

Mohjive ( 2014-01-14 00:27:31 +0300 )edit

Ok thanks :) Tried again, with no error messages this time. I also deleted the 20hybris-led.ini I had edited and replaced it with the original. But still no led.

ssahla ( 2014-01-14 00:35:47 +0300 )edit

Same here, I tried it earlier (noticed the typo) but the LED didn't get fixed. Worst of all, after a reboot for a moment I had this issue: http://youtu.be/BB56cz7MxuU This video is not mine, I just happened to see it earlier today. I got rid of this with a reboot, but the LED issue still persists.

ottulo ( 2014-01-14 00:59:02 +0300 )edit

I've seen the blinking display as well. I got it when I restarted the mce service a couple of times. I solved that by locking and unlocking the display with the power button.

Mohjive ( 2014-01-14 01:18:00 +0300 )edit
Login/Signup to Answer

Question tools



Asked: 2014-01-13 18:31:36 +0300

Seen: 612 times

Last updated: Jan 14 '14