Ask / Submit
17

Automatic Wifi Switching?

asked 2014-01-13 19:23:22 +0300

stephan gravatar image

updated 2014-02-18 16:19:21 +0300

chemist gravatar image

Hi, I have in my flat 2 Wifis. Both are registered in the Jolla. Now the reason for having 2 wifis is of course, that depending on wich room I'm in, only one of the signals is strong enough. Unfortunately the phone does not seem to switch signals automatically. If it's connected to Wifi 1 and I move over to a room with wifi 2 it does not seem to automatically reconnect to the stronger signal. It just complains that it has connection problems. It would be cool, if the phone would automatically reconnect to the strongest signal. Plus switching wifis is cumbersome: go to settings, disconnect from wifi 1, connect to wifi 2 - it seems to be too complicated ...

edit retag flag offensive close delete

Comments

I have the same Setting in my flat with two wifis. and i have exactly the same Problems. But there seem to be General Problems with wifi Connection "Connection Problems": https://together.jolla.com/question/6113/lots-of-connection-errors-while-on-wifi/

Zandi ( 2014-01-13 19:43:11 +0300 )edit

Try to use the same SSID/PSK on both APs. I don't have two routers now to try this with Jolla, but I've seen earlier certain devices behave better in such an environment.

const ( 2014-01-13 20:04:05 +0300 )edit

@const: they are the same - but still I have these problems ...

stephan ( 2014-01-13 20:29:30 +0300 )edit

@Zandi: other than my problem/request wifi seems to be stable enough for me. I would not say that I have general problems with wifi ...

stephan ( 2014-01-13 20:32:26 +0300 )edit
2

the problem with this is that AP signals strengths fluctuate constantly, making the chance of constant flip flopping between connections greater. Bridge the two AP's and use the same SSID, it's known that conman has issues with this setup, though. You dont need to disconnect first, just connect

llornkcor ( 2014-01-14 08:38:03 +0300 )edit

2 Answers

Sort by » oldest newest most voted
4

answered 2014-02-18 16:07:34 +0300

chemist gravatar image

The approach of yours is somehow weird, your wlan setup at home should have wireless roaming capabilities, shared SSID/Login/DNS and you should not run into these problems anymore. Depending on your infrastructure, repeater or bridge mode of your router could solve this for all devices not only for your Jolla. Note that wlan-roaming only works with a roaming setup as only then your clients can do a proper handoff. Note what happens in step 3 below!

What is Roaming and How Does it Work?

Roaming occurs when a wireless client device moves outside the usable range of one wireless access point (AP) and connects to another AP—usually one with a stronger signal. There is no “roaming” issue as far as the AP is concerned. As long as the APs are setup properly, client devices can roam seamlessly from one AP to another. The issue and challenge comes in the actual “handoff ” process, which, according to the IEEE 802.11 standard [1], is dictated by the client device. The handoff is the process of the client device disconnecting from one AP and then re-associating with another. This process consists of 3 phases:

  1. Scanning : As the device moves away from the AP to which it is connected and the RSSI (Received Signal Strength Indicator) values begin to drop below certain levels, the client device sends out probe packets to identify AP alternatives. Upon discovery of accessible APs, the device then selects its next AP based on certain criteria, as defined by the device itself.
  2. Authentication: During this phase, the client device sends an authentication request to the new AP and waits for a response from the AP to approve or reject the request.
  3. Re-association: Upon approval by the new AP, the client sends a re-association request and waits for a response. Once the re-association is complete, the new AP sends out a disassociation packet to the old AP so that the routing tables can be updated. The handoff process is now complete.

http://hometoys.com/emagazine.php?art_id=1909

edit flag offensive delete publish link more

Comments

Yes, your approach is technically the right one for "stefan" to overcome his problems.

But still, the problem consists, as the two WiFi's may not belong to one person. E.g. my parents Wifi - network has it's own SSID and my Wifi network with other SSID consists out of three router, which provides roaming. For reason I don't wanna combine this two networks, but would be nice to walk over to my parents and my phone would do the same.

Vieno ( 2014-02-18 16:37:29 +0300 )edit
1

@Vieno solving a so very local issue is hard. There is no technical solution to it as this is no roaming at all as you get different IPs each time and need to reconnect all services if you do so. One could write a daemon triggering a reconnect if such situation applies... on a buggy connection it will reconnect to a known network anyways if connection is lost. I have 2 known SSIDs at work and sometimes it swaps between them even though the AP is the same hardware - no issues WFM

chemist ( 2014-02-18 16:51:43 +0300 )edit

I have this setup, but the Jolla still tries very much to use the access point it originally connected to. Even if the other AP signal is many times stronger... Then finally it fails altogether talking to the remote (but original) AP and fails over. The logic in the selection of current AP seems to be flawed....

dag ( 2015-08-15 15:32:43 +0300 )edit
1

answered 2014-02-13 12:10:11 +0300

richhanz gravatar image

This script and, when necessary, WLAN off and on in settings forces the connection with the preffered WLAN accesspoint.

The command connmanctl disable wifi and connmanctl enable wifi seems to have te same effect as reloading the wlan module. A visible difference between connmanctl and reloading the wlan module is that with connmanctl the WLAN icon status is correct and with reloading the wlan module the WLAN icon status is incorrect; the WLAN icon status remains off, even with a working connection. The WLAN icon status is correct again after toggling it on, off and on again.

edit flag offensive delete publish link more

Comments

A useful command - thanks!

tingo ( 2014-02-13 12:18:28 +0300 )edit
Login/Signup to Answer

Question tools

Follow
4 followers

Stats

Asked: 2014-01-13 19:23:22 +0300

Seen: 1,361 times

Last updated: Feb 18 '14