Ask / Submit
2

Connecting jolla to pc via USB cable not working

asked 2016-09-12 21:49:34 +0200

d gravatar image

I was never able to connect and share files with pc. When I connect the device, it is recognized by the system, and it starts charging, but I'm not able to exchange files because no mass storage tag is shown in the pc device list.

I'm on windows 10. I tried many of the methods previously suggested in some other questions, i.e. https://together.jolla.com/question/111519/jolla-device-as-an-drive-viewable-on-windows/ https://together.jolla.com/question/126730/connect-to-pc/ https://together.jolla.com/question/134914/phone-not-visible-in-windows-7/ and other more.

edit retag flag offensive close delete

Comments

1

Is the RNDIS driver installed on your Windows 10 PC?. on my Windows 7 installation, RNDIS shows under Network Adapters as Remote NDIS based Internet Sharing Device. This is essential for communication between device and PC. Connect your device to your PC and then check in device manager to see what's what.

Edz ( 2016-09-13 12:04:41 +0200 )edit

Sorry for being the bearer of bad news but Jolla specifically states in virtually all its SFOS releases that windows 10 is not supported in any case whatsoever. I haven't tried running windows 8 or 7 in a virtual machine right on windows 10 to see if Jolla can be made to communicate withe the pc running windows 10 in that way. I do not have windows 10 installed on my PC, you might want to give it a try

DameCENO ( 2016-09-13 14:30:30 +0200 )edit

No, I have not them, how to install? Anyway, I did some operations, like connecting to a virtualized windows xp, and now when connecting in win 10 it shows a new mass storage unit, but it's not accessible (clicking on it triggers the message "insert a disk in F:").

d ( 2016-09-13 16:34:09 +0200 )edit

for 2.0.2.51 Both Developer Mode(RNDIS) and PC Mode(MTP) Work on my Work Win10 PC Though Developer Mode failed on Win10 in 2.0.1.x

I've made no effort to get it going.

GD ( 2016-09-14 05:45:40 +0200 )edit

What's the difference between RNDIS and MTP? And anyway, how do I get those drivers? Are you using win10 home or N version?

d ( 2016-09-14 14:03:23 +0200 )edit

2 Answers

Sort by » oldest newest most voted
1

answered 2016-09-14 19:30:58 +0200

DrYak gravatar image

updated 2016-09-14 19:31:42 +0200

A possible fall back option would be to :

  • install Developer Mode on the Jolla (it installs the RNDIS support and a SSHD server)
  • turn on the Developer USB Mode on the Jolla (it uses the RNDIS to show up as a network device instead of a MTP file storage)
  • use FileZilla on Windows to access the files securely over SFTP
edit flag offensive delete publish link more

Comments

Please, tell me how EDIT: Ok, I found how, under SFTP, Host: 192.168.2.15, User: nemo, Password: that in the developer mode. When I try to connect, it reaches the 20 seconds timeout, and disconnects... how to fix this?

d ( 2016-09-15 15:21:17 +0200 )edit

That's weird.

On the Jolla side :

  • in settings -> developer tools : check that Remote connection (allow login via SSH with username 'nemo') is enabled
  • in settings -> USB : check that the Developer mode is selected

On the FileZilla side :

  • File -> Site manager
  • Check there that the Protocol: is set to SFTP - SSH File Transfer Protocol
  • Check that the Port: is empty, or set to 22.
  • As a Logon type: you could use, e.g.: Ask for password

Connection should be immediate, and the first time FileZilla will ask you to confirm the SSH fingerprint of the Jolla's SSH server.

DrYak ( 2016-09-16 14:37:53 +0200 )edit

More basic checks:

On the Windows console ( cmd ):

  • type ping 192.168.2.15. Can you manage to get an answer from the Jolla ?
  • ipconfig /all Does the USB Network device ( = that's the Jolla in Dev Mode) has a valid address (eg.: 192.168.2.1 )
DrYak ( 2016-09-16 14:42:25 +0200 )edit

Ping returns: "Host destination not reachable" everytime.

d ( 2016-09-17 18:14:48 +0200 )edit
1

For some reasons, the network isn't established.

You should open the properties of the USB network device, select the TCP/IP module, and manually set the IP to 192.168.2.1 (instead of automatic DHCP).

Then the ping command should work and filezilla should be able to find the Jolla.

(Or you can skip the USB thing altogether, and use the IP that the jolla has on Wifi network. It is also displayed on the "Developper tools" pane of Settings)

DrYak ( 2016-09-21 20:05:03 +0200 )edit
1

answered 2016-09-15 09:36:36 +0200

spiiroin gravatar image

There are a number of fixes to the mtp functionality in 2.0.2. The basic functionality (browsing, down/uploading) has been tested at least with windows 7, windows 8.1, windows 10 and ubuntu 14.04 (both libmtp and gphoto2 backends).

While these changes are not highlighted in the release notes, they can be found from changelog under "buteo-mtp-qt5".

Note: My understanding is that some windows 10 variants might not support mtp out of box, but installing "Media Feature Pack" (https://www.microsoft.com/en-us/download/details.aspx?id=48231) should help.

There are still reported issues with ubuntu 16 (possibly related to libmtp changes at pc side, so other distros may be affected as well). These can hopefully be remedied in the future releases.

edit flag offensive delete publish link more

Comments

Mine works fine under Win10. However in both Win10 and Win7 it will only connect and show device if I have no running apps on the phone. Don't know why. It took me quite a while to figure that one out. :-)

pseudoscion ( 2016-09-15 10:05:28 +0200 )edit

The result of not choosing a over the air/browser based solution from the start. :/

ApB ( 2016-09-15 10:58:02 +0200 )edit
Login/Signup to Answer

Question tools

Follow
3 followers

Stats

Asked: 2016-09-12 21:49:34 +0200

Seen: 878 times

Last updated: Sep 15 '16