J1& Aurajoki & Crappy Networks = Mostly Disconnected?

asked 2016-09-12 22:40:36 +0300

Robomike gravatar image

Not really a question... beforehand I have to explain the situation: I live in a basement apartment. Since I had my Jollas I found:

  • One meter outside of my window I have a pretty and usable 4G signal.
  • Also there and up till just the window ledge I may have a weak 3G connection sometimes.
  • Further inside there's only 2G. All sailfish versions since 2013 up to Taaloj√§rvi have had issues with weak 3G signals. Data connections seems to be established, but no data flow at all. Getting an incoming call, I needed to do a yoga exercise with the phone close to the window, otherwise the call was interrupted, the indicator switched back to 2G and I could recall then. Or the phone had 2G from the beginning on, then it was no problem. I received SMS in any case and just in time. Over all, it was not funny, but I could live with.

Yesterday I updated to Aurajoki and noticed a completely different behavior:

  • the phone claimed to have 4G established, even directly after reboot.
  • trying an outgoing call or trying to call the phone from fixed line the connection collapsed immediately. Outgoing: no network, ingoing: no response.
  • the connection did not reappear for minutes, so I don't know, if at all.
  • of course, SMS weren't receivable
  • selecting the "3G preferred"-mode was not helpful. Connection disappeared as before.
  • selecting the "2G only"-mode in settings was indeed a workaround. But I'm not willing to change the settings whenever I leave my flat and - more important - come back.

I've read somewhere here that the related thing in Aurajoki is different from Espoonjoki, so I updated to 2.0.3.11, and it was fixed. It's now better than ever, seems the voice connection keeps stable now. So, if someone has similar problems, there's a little hope.

edit retag flag offensive close delete

Comments

Interesting but how to update to Espoonjoki?

strobovalo ( 2016-09-12 23:35:55 +0300 )edit

@strobovalo - to update to Espoonjoki, open terminal and type in;

ssu re 2.0.3.11 enter

version --dup emter

I'm to understand that this is not the safest way to upgrade, but I have often used the above method without any realistic problems; although it may be best to unapply any patches being used by Patchmanager.

Edz ( 2016-09-13 00:00:42 +0300 )edit

Thank you but i was reading that Espoonjoki is only for turing phone and next update for al SFOS phones is 2.0.4

strobovalo ( 2016-09-13 00:06:50 +0300 )edit

@strobovalo Any references ?

kat6 ( 2016-09-13 07:27:48 +0300 )edit

@strobovalo - I've already had Espoonjoki running on my Jolla1, the only reason I turned back to Aurajoki is because Developer Mode had stopped functioning with Espoonjoki and I couldn't be bothered to mess around trying to get it working, rolling back was easier and quicker.

Edz ( 2016-09-13 11:33:18 +0300 )edit