Ask / Submit
1

[2.0.2.51] SFOS update app missing [answered]

asked 2016-09-26 13:36:10 +0200

mdosch gravatar image

updated 2016-09-26 14:21:00 +0200

I just realised there is no more item to check for new SFOS Update (the one where the lakes/rivers are shown in background) in my settings app. Was this removed and can be found somewhere else or did something go wrong when updating to 2.0.2.51? I also realized I had to re-enable developer mode for SSH-access again.

I searched TJC for missing update app but didn't find anything so it seems it's not a common problem which affects a lot of people.

Edit: I'm using Jolla 1

edit retag flag offensive reopen delete

The question has been closed for the following reason "the question is answered, an answer was accepted" by Alex
close date 2016-09-27 00:20:11.788461

Comments

it's still there in Settings on my Jolla @ 2.0.51

till ( 2016-09-26 13:53:58 +0200 )edit

mine is there, Jolla 1 @ 2.0.2.51.

magullo ( 2016-09-26 13:56:13 +0200 )edit

@mdosch, you have managed to somehow lose it from your device.... maybe some tweak/patch done wrong?

juiceme ( 2016-09-26 14:31:19 +0200 )edit

Probably version --verify (in terminal) will tell you missing or obsolete OS components.

objectifnul ( 2016-09-26 14:45:27 +0200 )edit

I had a similar issue https://together.jolla.com/question/141751/cannot-access-sailfish-os-updates-section-via-settings/ but you've already been provided an answer, I see!

spidernik84 ( 2016-09-26 19:35:01 +0200 )edit

1 Answer

Sort by » oldest newest most voted
3

answered 2016-09-26 14:52:53 +0200

Alex gravatar image

Seems that something messed up your settings (e.g. a patch?!).

You can either try to

  • install possibly missing packages with the command version --dup

or

  • reinstall the settings with pkcon install jolla-settings-sailfishos.

To execute this commands in the Terminal app you need to activate developer mode in settings. :)

edit flag offensive delete publish link more

Comments

1

Thank you, version --dup fixed it for me.

But I wonder what caused the loss of jolla-settings-sailfishos as I'm not using patches. Maybe some conflict due to openrepos as I think I forgot to deactivate before doing the last update.

mdosch ( 2016-09-26 23:34:33 +0200 )edit

Question tools

Follow
1 follower

Stats

Asked: 2016-09-26 13:36:10 +0200

Seen: 374 times

Last updated: Sep 26 '16