Ask / Submit
6

Not able to turn my mobile network connection on

asked 2016-10-05 16:03:45 +0300

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

updated 2016-10-05 17:29:59 +0300

jiit gravatar image

In the preferences menu, there are on top four symbols (plane mode, wifi, mobile network and bluetooth) with grey lights. There are three grades of brightness for the lights. Wifi, bluetooth and plane mode is middle-grey, when inactive, and bright, when active. The problem: By clicking on mobile network nothing happens. The light stays at the lowest grade, very dim. I went to -> System -> mobile network: in the upper right corner my connection / provider is mentioned: T-Mobile A The next entry is: Data roaming. [works probably, but won't help] The next: MMS access point [works] Then: Network mode [4G - works] Eventually: Select network automatically. [works] I would very much like to have a look on the apn data of the internet connection, but -> it can't be found! There should be a switch for Mobile Data, where I could edit my settings.

edit retag flag offensive close delete

Comments

Did you check the entry below Roaming and before mms access point? There should be Data access point where you can check your provider settings. If they are wrong you can not connect. I assume you didn't see headlines as such since the segment is first called Mobile data (headlines have a different color then sub entries like roaming). To make sure your mobile network is working you need to also have a signal to network first otherwise the grey dot stays grey and can't be activated.

PatsJolla ( 2016-10-05 16:34:01 +0300 )edit

I have exactly the same problem since I got a new SIM from my provider. All settings are correct.

paulvt ( 2016-10-05 23:06:47 +0300 )edit

1 Answer

Sort by » oldest newest most voted
6

answered 2016-10-06 13:44:45 +0300

paulvt gravatar image

I fixed it by nuking my oFono state directory:

$ devel-su
...
# systemctl stop ofono
# mv /var/lib/ofono /var/lib/ofono.bak
# systemctl start ofono

Not the most elegant solution, and also not one that uncovers what was wrong, but it worked.

edit flag offensive delete publish link more

Comments

Do you have to repeat this any time it happens or is it permanent?

peperjohnny ( 2016-10-16 12:24:10 +0300 )edit
1

It's permanent. I suspect it has something to do with the new dual-SIM support and having an old oFono setup.. once wiped it works.

See also: https://together.jolla.com/question/148246/bug-new-sim-crazy-behavior/

paulvt ( 2016-10-16 14:29:29 +0300 )edit
1

Worked for me and T-Mobile. Thanks!

lispy ( 2016-10-24 11:37:21 +0300 )edit

It's not remembering the state anymore if we do this even if we copy back the folder :(?

pinkpanther ( 2016-11-01 17:32:25 +0300 )edit

I am not sure what you mean, @pinkpanther? Could you elaborate?

paulvt ( 2016-11-02 22:11:44 +0300 )edit
Login/Signup to Answer

Question tools

Follow
2 followers

Stats

Asked: 2016-10-05 16:03:45 +0300

Seen: 498 times

Last updated: Oct 06 '16