Ask / Submit
15

[Bug / New Feature Requirement] Sailfish OS 2.0: proxy settings for WLAN

asked 2016-10-06 09:59:35 +0300

walkingzen gravatar image

updated 2018-08-08 09:35:31 +0300

In my new Aquafish, the WLAN is behind proxy. My proxy is a http one; i.e. it is http://10.3.100.207:8080. I could use the same for http and https. It works smoothly in my laptop where I am using Manjaro.

Unfortunately, the proxy settings in Aquafish ask to use https::// for https proxy. I could not use http scheme. The main issue is that WLAN is not working. I have searched through this together.jolla.com and all the questions are 2 year old questions and seems that there is not solid answer. Only one work around I could see is using redsocks and libevent and modifying iptables settings or something. As I am newbie to this OS, I am reluctant to play with it by modifying things through terminal. (However, I am ready to try something through terminal if proper documentation is available which not available as of now from my perspective)

So my questions are: Kindly let me know the method for setting the proxy value a http://10.3.100.207:8080 for all_proxy. It will be great if I could know if someone could make it work in their phone and their method.

Do we have any files (like /etc/environment, .bashrc or proxy.sh ) which could be modified so that my mobile will use the proxy settings. I am facing lots of issues as I am forced to use the paid data packs in 24 X 7 WiFi zone. Please help. None of the questions in the together.jolla regarding the proxy is answered properly. Please help

Edited after 2.0.4 update.

The issue with proxy still persists. Still the browser and jolla store is not taking the proxy.

I would really appreciate if anybody could provide some method to use the proxy as it is not working and stuck for long time. I tried setting http_proxy and HTTP_PROXY in /etc/profile.d. But it is not working.

----------------EDIT ---------------------due to frustration -----------------------------------------------------------------

I feel so bad that I could not get any response that could fix the issue so far. Everyday I visit this page and see if somebody replied. I think I have tried almost everything I know about linux configurations. Another option was to change the ip-tables, installing sudo and all. It looks complicated for me and seems insecure for me. Hence I didn't go for it. (Again for that - to install the sudo we need to change the repo and all). It is very frustrating when you pay for data when you are staying in 24 X 7 free wifi zone.

EDIT - something has been worked - but don't know the reason

Today when I checked I have seen that in developer terminal I could see HTTPS_PROXY as I have set the env variables in profile.d/proxy.sh. Hence I tried to access browser from there and I could connect to internet. But when I tried store-client it didn't work properly. It asks for different login and stuffs. It seems that the proxy value is not available at GUI for any application. I am not sure why is it happening like this.

If anybody got some hint how I could use the applications without running from the terminal.

Just to Bring Up My Post (BUMP). Again BUMP . Again BUMP

I know that bringing up the same post again and again is not good. But I don't have any other way out. If I knew, how to fix it, I could have fixed earlier :( Developers, please help.

New update:

IF I could run harbour apps from terminal the it uses the proxy. But the android apps won't use the proxy even if it is ran from terminal. Kindly do the needful to use the proxy even if it access directly.

New update: Now on Sailfish 2.1.2.3

I tried updating the about:config of the browser then the browser honours the proxy. Hence it go back to the original question, is there any config file which is honoured by all the applications like /etc/environment etc.. It would be great if somebody could let me know any config file which could be modified to use it across the OS.

Just a reminder

Would it be possible for you to consider the proxy issues in coming update? It would be quiet useful for the people who are under institutional proxy.

Just to Bring Up My Post (BUMP). Again BUMP . Again BUMP

I know that bringing up the same post again and again is not good. But I don't have any other way out. If I knew, how to fix it, I could have fixed earlier :( Hope it may be included in next update. :D

Regards, Sree

edit retag flag offensive close delete

Comments

Does leaving the 'https://' line blank, and filling only the 'http://' one, help? If that doesn't help, then just check if it works with 'No Proxy'; some proxy setups that haven't been performed properly leave ahole for direct access to the outside.

kat6 ( 2017-06-06 09:12:59 +0300 )edit

@kat6. Thank you for reply. It is not working. It is open issue for long time with proxy issue. I am not sure if somebody is working on it as it may not applicable for many people. The problem is really with proxy. The WiFi network connects but none of the application could use it.

walkingzen ( 2017-06-07 08:50:33 +0300 )edit

3 Answers

Sort by » oldest newest most voted
1

answered 2016-10-06 12:36:06 +0300

phklrz gravatar image

Hello,

if you go in Settings > WLAN, long press on the Wifi connection you are connected to > Modify then you can set the proxy settings.

However on Jolla Phone 1, the native browser does not use the proxy settings !

edit flag offensive delete publish link more

Comments

1

I have set the proxy using the Setting WLAN, but it is not working for me. Hence I have raised this issue. I am using Aquafish which uses SailFish OS 2.0. Is it same with Jolla Phone 1? Is there any work around?

walkingzen ( 2016-10-06 13:30:28 +0300 )edit
2

answered 2016-10-16 21:05:12 +0300

Bart S gravatar image

updated 2016-10-17 14:58:06 +0300

It is possible to set a http:// proxy scheme and below that you set the port number

As @phklrz said, Go to the Settings -> WLAN and select the network In the WLAN list of networks long click the network and press Edit.

In proxy configuration select Manual and immediately below that line enter http://10.3.100.207 Below this line you see the label HTTP proxy ( this also still confuses me, that the label is blow the line you enter). Note that you do not have to enter HTTP:// yourself...

Then below the HTTP proxy label you have to enter the port number 8080.

That should be all to enter the proxy. Or if your proxy also supports the other protocols, you have to enter the proxy details as well for the other protocols.

Just in case (you don't mention in your question) if you need a static IP address, you have to scroll all to the bottom of the screen and untick "Auto-retreive IP address" which allows you to enter a static IP address for your Aquafish

EDIT:

After receiving the comment, I have tried again and I think now I get what is the issue. When you enter the http:// proxy, you must have the scheme in the line that contains the IP address. If compare to a browser, you can add an IP address and port number for each protocol, but you do not add specify the scheme to the IP address.

What you still can try is just add the same IP number and port number for all protocols. Or you set proxy to automatic and add your ip-address:portnumber to the proxy address. If that does not work either, I think you should file a bug report

edit flag offensive delete publish link more

Comments

@Bart S , @phklrz , Thank you for your replies. I have set the proxy earlier itself using same mechanism. i.e. Long click on the network and edit etc. But my phone is not working with WiFi. The Wifi says it is connected then suddenly changes to limited connectivity or Open/Secure status. In addition to that, in my laptop and other systems we use same http:// proxy for http and https proxies. (otherwise using all_proxy environment variable) as we had only http proxy no https proxy server. But as you can see the https proxy field doesn't allow us to enter http://..... This is the issue. I am not sure still I could convey my real problem. Hope you could get it now.

walkingzen ( 2016-10-17 14:47:28 +0300 )edit

@Bart S, Thank you for the edit. I have tried the option of the same IP number and port number for all protocols. But here the problem is that the protocol is set automatically. As we don't have https://... and have only http://.... I think it is not working properly.

Regarding bug report - I raised this issue as I am facing it :). Do I need to raise bug report in any other forum?

Any idea, which file is used by Sailfish for proxy settings like /etc/environment, .bashrc etc?

walkingzen ( 2016-10-17 15:10:57 +0300 )edit

As far as I know there is no official bug tracking system publicly available. What most users do here is adding [bug report] in front of the question title.

Bart S ( 2016-10-18 09:29:35 +0300 )edit

I thought adding the bug tag, it may reported as bug. Hence I reported with tag bug

walkingzen ( 2016-10-18 12:22:34 +0300 )edit
1

answered 2016-12-19 18:04:38 +0300

r0kk3rz gravatar image

This question is a bit of a duplicate, I see you've already found this one and commented: https://together.jolla.com/question/22824/proxy-settings-arent-honoured/

The proxy settings have never really worked, and I never found any method of fixing it so it remains an open issue for now.

edit flag offensive delete publish link more

Comments

@r0kk3rz This was a issue raised long back and somewhere I read it because of lack of gecko engine and which will be added in later versions. But I couldn't find any effect of that. Again some solutions using iptables didn't look secure for me.

It is interesting to see that even putting proxy in bashrc, or such files also not honoured by the GUI. But most of the DE in GNU/Linux works properly. Although something like Deepin use the proxy set in their control center. Atleast, if could have a config file which used by the GUI which could be very helpful.

The thing that hurts me most is I am paying for data when I am living in 24 X 7 wifi zone :(

walkingzen ( 2016-12-19 20:46:40 +0300 )edit

Yeah the browser is the one thing that does work i think, its been a while since i've looked at it

r0kk3rz ( 2016-12-19 21:01:56 +0300 )edit

@r0kk3rz Will it work in the same way arch linux works by adding env variables in /etc/sudoers (after installing sudo) after setting the proxy in proxy.sh in profile.d? If yes, please tell me how could I install sudo.

walkingzen ( 2016-12-29 21:23:27 +0300 )edit

@walkingzen, env variables would need to be set for nemo user, you dont need sudo to do that. i'm not sure if that would work though

r0kk3rz ( 2017-01-02 12:03:00 +0300 )edit

@r0kk3rz Thanks for reply. Happy new year. It is not working. I have set for the users using proxy.sh in profile.d. It is strange that most of the methods used in other linux variants won't work here. I have even tried by using /etc/environment. Any clue so that I could use every applications including android ones;

walkingzen ( 2017-01-03 07:50:12 +0300 )edit
Login/Signup to Answer

Question tools

Follow
5 followers

Stats

Asked: 2016-10-06 09:59:35 +0300

Seen: 2,080 times

Last updated: Aug 08