Ask / Submit
2

Camera not working

asked 2016-10-12 20:49:43 +0300

daniel057 gravatar image

updated 2016-10-14 10:45:22 +0300

jiit gravatar image

I think i deleted gstreamer library which uninstalled my camera app. I installed jolla camera again but it does not work now. I saw another post where it said to use sudo zypper commands but when i use them it says command not found.

edit retag flag offensive close delete

Comments

@daniel057 Install zypper by using the command pkcon install zypper and try again. Or, are you talking about the sudo command maybe... If that's the case, you first have to do devel-su (and not sudo) before entering the zypper command.

ced117 ( 2016-10-12 22:15:25 +0300 )edit

Thanks @ced117. I reinstalled the plugin through zypper but still camera is not working. Wat else shud i do?

daniel057 ( 2016-10-13 07:08:28 +0300 )edit
1

@daniel057 When you run jolla-camera from the terminal, what is the output ?

ced117 ( 2016-10-15 01:10:45 +0300 )edit

jolla-camera [D] QWaylandEglClientBufferIntegration::QWaylandEglClientBufferIntegration:62 - Using Wayland-EGL [D] QGstreamerVideoWindow::QGstreamerVideoWindow:72 - No m_videoSink available!

[W] QCameraFocusFakeFocusControl::setFocusMode:83 - Focus mode selection is not supported [W] QCameraFocusFakeFocusControl::setFocusPointMode:87 - Focus points mode sele ction is not supported [W] unknown:181 - file:///usr/share/jolla-camera/pages/CameraPage.qml:181:5: QM L DBusAdaptor: Failed to register servicecom.jolla.camera

(jolla-camera:18793): GStreamer-WARNING **: Name 'video-encodebin' is not uniqu e in bin 'camerabin', not adding

(jolla-camera:18793): GStreamer-WARNING **: Name 'videobin-filesink' is not uni que in bin 'camerabin', not adding

(jolla-camera:18793): GStreamer-WARNING **: Name 'image-encodebin' is not uniqu e in bin 'camerabin', not adding

(jolla-camera:18793): GStreamer-WARNING **: Name 'imagebin-filesink' is not uni que in bin 'camerabin', not adding

(jolla-camera:18793): GStreamer-WARNING **: Name 'viewfinderbin-queue' is not u nique in bin 'camerabin', not adding [W] CameraBinSession::processBusMessage:1027 - CameraBin error: "Your GStreamer installation is missing a plug-in." [W] unknown:16 - file:///usr/share/jolla-camera/pages/capture/CaptureOverlay.qm l:16:1: QML CaptureOverlay: Binding loop detected for property "_startTime" [W] QQmlImportDatabase::registerPluginTypes:1875 - Module 'QtDocGallery' does n ot contain a module identifier directive - it cannot be protected from external registrations. [D] QOfonoNetworkRegistrationInterface::getProperties:238 - "Method "GetPropert ies" with signature "" on interface "org.ofono.NetworkRegistration" doesn't exi st " [D] QGstreamerVideoWindow::QGstreamerVideoWindow:72 - No m_videoSink available!

[W] SignonUiServiceType::componentComplete:50 - virtual void SignonUiServiceTyp e::componentComplete() CRITICAL: unable to register signon ui service: "com.jol la.camera" at object path: "/JollaCameraSignonUi" [W] QCameraFocusFakeFocusControl::setCustomFocusPoint:90 - Focus points selecti on is not supported [W] QCameraFocusFakeFocusControl::setCustomFocusPoint:90 - Focus points selecti on is not supported [W] QQmlEnginePrivate::~QQmlEnginePrivate:572 - "There are still "1" items in t he process of being created at engine destruction."

daniel057 ( 2016-10-15 20:12:24 +0300 )edit

4 Answers

Sort by » oldest newest most voted
2

answered 2016-12-03 12:21:51 +0300

klampfenfreak gravatar image

ok, got it solved. Remove every gstreamer library with zypper, which has no dependencies to the system. A warning is shown if so. Remove jolla-camera app. Deactivate 3rd part repos, which has gstreamer libraries included (this step is not necessary I think). Than run : sudo zypper install jolla-camera and sudo zypper install gstreamer* I also had to install jolla-mediaplayer, again.

best regards

edit flag offensive delete publish link more

Comments

this worked only partially for me... I was missing the app too.. now its back but when I start it I get a test picture like in old tv times.

what else can I try?

PatsJolla ( 2016-12-08 18:00:50 +0300 )edit
0

answered 2016-11-30 19:13:11 +0300

klampfenfreak gravatar image

same problem on my intex aqua fish. tried to upgrade gstreamer ugly and bad and removed it to solve an update issue, now jolla-camera does not work anymore. How can we fix this?

tried removing and reinstall of gstreamer and jolla-camera, both with zypper and pkcon, already... thank you!

edit flag offensive delete publish link more
0

answered 2016-12-04 03:09:37 +0300

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

updated 2016-12-04 03:09:37 +0300

MSameer gravatar image

You are probably missing gstreamer1.0-droid

Try this: zypper in -t pattern -f jolla-configuration-l500d I am not sure what the pattern is for AquaFish though :(

edit flag offensive delete publish link more

Comments

Hi! This worked for me! My intex aqua didn't play any mp3's (other formats worked ok) and jolla-camera didn't show any picture. Camera in Telegram worked ok though so i did use that for a few days now.

so now i did:

devel-su

pkcon install gstreamer1.0-droid

I've been removing and installing other gstreamer packages with pkcon and zypper, but they never pulled this one for installation. Which left the system a bit broken.

This also affected alarm clock, but thanks to great programming from Jolla people alarm still played the default alarm sound when it noticed that there was no way it can play my favourite alarm tune :)

Thumbs up!

Wizor ( 2016-12-14 10:42:47 +0300 )edit
0

answered 2019-01-06 11:57:36 +0300

clementb gravatar image

Hello,

I go same probleme, front camera is not working : no picture only black but back camera is fine. jollal_camera has been uninstall-reinstall but issue still.
I didn't reinstall gstreamer, as it seems issue is to read camera config - see hereunder details - Is it correct ? any idea ? thanks have a nice year !


[nemo@Sailfish ~]$ jolla-camera [D] unknown:0 - Using Wayland-EGL [W] unknown:0 - Error reading filesystem properties: "org.freedesktop.DBus.Error.InvalidArgs" "No such interface 'org.freedesktop.UDisks2.Filesystem'" "/org/freedesktop/UDisks2/block_devices/mmcblk1" [W] unknown:0 - Error reading encrypted properties: "org.freedesktop.DBus.Error.InvalidArgs" "No such interface 'org.freedesktop.UDisks2.Encrypted'" "/org/freedesktop/UDisks2/block_devices/mmcblk1" [W] unknown:0 - Error reading encrypted properties: "org.freedesktop.DBus.Error.InvalidArgs" "No such interface 'org.freedesktop.UDisks2.Encrypted'" "/org/freedesktop/UDisks2/block_devices/dm_2d1" [W] unknown:0 - Error reading encrypted properties: "org.freedesktop.DBus.Error.InvalidArgs" "No such interface 'org.freedesktop.UDisks2.Encrypted'" "/org/freedesktop/UDisks2/block_devices/dm_2d0" [W] unknown:0 - Error reading encrypted properties: "org.freedesktop.DBus.Error.InvalidArgs" "No such interface 'org.freedesktop.UDisks2.Encrypted'" "/org/freedesktop/UDisks2/block_devices/mmcblk1p1"

(jolla-camera:13533): GStreamer-CRITICAL **: 10:24:30.576: Registering meta implementation 'NemoGstBufferOrientationMeta' without init function

(jolla-camera:13533): Tracker-WARNING **: 10:24:30.655: Locale '0' is not set, defaulting to C locale

(jolla-camera:13533): Tracker-WARNING **: 10:24:30.655: tracker-backend.vala:211: Falling back to bus backend, the direct backend failed to initialize: Locale change detected (DB:fr_FR.utf8, User/App:C)

edit flag offensive delete publish link more
Login/Signup to Answer

Question tools

Follow
3 followers

Stats

Asked: 2016-10-12 20:49:43 +0300

Seen: 875 times

Last updated: Jan 06