[bug] New SIM: crazy behavior

asked 2016-10-12 21:17:25 +0300

cy8aer gravatar image

updated 2016-10-12 21:30:10 +0300

I tried out a new prepaid SIM (Germany O2). I started with the Jolla1. No data connection possible. Moved the SIM card to JollaC. No data connection possible. I swapped to the second card (Telekom). When the phone showed 4G I swapped to the first (O2) card again and it - worked. With 4G.

Moving the card to the Jolla1: No connection. Inserting another (older) O2 card into the Jolla1: works. Probably this is the same problem that someone had in another thread who could not create a data connection.

Both phones are

[Update] when moving back to the JollaC I need to do the 2nd SIM swap trick again to get it working.

[Update] https://together.jolla.com/question/147769/202-20413-after-losing-wifi-mobile-data-doesnt-work/ <-- I meant this thread

[Update] When no data connection in the mobile data settings "Internet deactivated" is shown. If it works it shows LOOP.

edit retag flag offensive close delete



Yes, I had this too! Glad to hear I'm not the only one that had troubles with a new SIM. I solved it on the Jolla 1 by completely nuking /var/lib/ofono (while the service was temporarily stopped of course)!

paulvt ( 2016-10-12 21:48:03 +0300 )edit

@paulvt: Thank you. that helped. Jolla1 works with the new card too.

cy8aer ( 2016-10-12 23:10:28 +0300 )edit

Maybe I should convert it into an answer. But it's not a good one. We're caught a bug here, probably in the double SIM support code. I am not sure how to give more visibility to this problem/bug... many people will have it in the future when they get new SIMs.

paulvt ( 2016-10-12 23:13:24 +0300 )edit

Yes, hopefully some @jolla guys should check this problem.

cy8aer ( 2016-10-12 23:31:52 +0300 )edit

The workaround for this bug like discussed above.

If you try: You do it on your own risk. If you do not know, what is described here or what is done with these commands: Don't do it! You may kill your phone functionality! Better wait for a fix from Jolla!

systemctl stop ofono.service
cd /var/lib
mv ofono ofono.backup
mkdir ofono
chown radio.radio ofono
systemctl start ofono.service
cy8aer ( 2016-10-13 09:01:24 +0300 )edit