Ask / Submit
8

[bug in community language packs] Muted volume indicator is missing [released]

asked 2016-10-12 23:58:56 +0200

nthn gravatar image

updated 2016-10-13 19:17:09 +0200

Where did it go? Before 2.0.4 there used to be an icon next to the battery percentage to indicate the ringtone/sounds is/are muted, but now it's gone and there is no indication whatsoever the ringtone is down to 0. I don't use any patches.

The issue occurs only when using community language packs (Nederlands and Hungarian is available on OpenRepos).

The bug's root cause lies in the 14th line of the /usr/share/lipstick-jolla-home-qt5/statusarea/ProfileStatusIndicator.qml file where the Profile.name is a blank string when using a community language pack.

Using the built-in British English language the Profile.name changes between "general" and "silent" which cause the icon showing up properly.

edit retag flag offensive reopen delete

The question has been closed for the following reason "released in a software update" by nthn
close date 2016-10-22 12:49:31.448199

Comments

1

Well for me it is still there on my Jolla Phone.

Alex ( 2016-10-13 00:15:48 +0200 )edit

Also still there for me on Jolla C with 2.0.4.13. Did you really mute ringtone and not the media playback volume?

raimue ( 2016-10-13 01:54:42 +0200 )edit

aquafish: still there

pawel ( 2016-10-13 08:35:21 +0200 )edit

Still there for me, too (J1 now). However, I think this issue was posted already some time ago, long before the 2.0.4 EA. It could be somthing that happens with updates if certain conditions are met. I frankly admit I'm too lazy to search for the old thread now, but if you find it, it might even contain a solution to your problem.

ossi1967 ( 2016-10-13 08:38:39 +0200 )edit

Oh, great. I'll see if I can find that old thread.

nthn ( 2016-10-13 09:14:08 +0200 )edit

3 Answers

Sort by » oldest newest most voted
2

answered 2016-10-21 18:51:29 +0200

@nthn It seems something is messed up with the RPM install section. It shall run the follwing command:

localedef --replace -i nl_NL -f UTF-8 nl_NL.utf8 --prefix=/

but it does not seems to be doing properly. If you run it as root the icon shall work as expected. I am working on the fixing of this.

edit flag offensive delete publish link more

Comments

@nthn Aw... I have managed to use $ instead of % in the post installation script so the language did not get properly registered. I have fixed it please test drive it from the openrepos. Thanks * A reboot might be required in this case.

martonmiklos ( 2016-10-21 20:23:49 +0200 )edit

Updated the language pack and rebooted, but the volume indicator is still missing (I've tried going back and forth between volume on/off but it doesn't change). Maybe it's something else still?

nthn ( 2016-10-22 00:05:47 +0200 )edit

Hmm.. On my JP1 it works now: http://imgur.com/a/dbM9G But on my Aqua Fish it does not.

martonmiklos ( 2016-10-22 00:20:43 +0200 )edit

@nthn Could you please uninstall the package and install it again? Unfortunatelly rpm's %pre scripts runs only the first "clean" installation of an RPM package.

martonmiklos ( 2016-10-22 00:23:46 +0200 )edit

Thanks! Uninstalling and installing it again did the trick.

nthn ( 2016-10-22 00:39:53 +0200 )edit
1

answered 2016-10-13 13:11:55 +0200

nthn gravatar image

Found it: https://together.jolla.com/question/41084/mute-indicator-missing-sinds-last-update/

The culprit seems to be the unofficial language pack, so now the question is: what? How is that even possible?

ping @martonmiklos, can you reproduce this problem with the Hungarian translation?

edit flag offensive delete publish link more

Comments

1

It happends with the Hungarian language too. I have no idea what could cause it, I will check out the QML source at the evening. To be honest I am using the localizaton almost from the begining, so I have not even noticed it.

martonmiklos ( 2016-10-13 14:13:39 +0200 )edit
3

Okay, I cannot stand it to not investigate it further now.

The display of that icon seems to be handled by the /usr/share/lipstick-jolla-home-qt5/statusarea/ProfileStatusIndicator.qml

https://gist.github.com/martonmiklos/5de1ac4cb15b281514fda37ca9186ba3

The icon depends on a comparison of the "silent" string with the Profile.Name coming from some ContextManager. In the code the "silent" is not a translatable string, so I assume that the Profile.name is coming from some the localized contents. It is clearly not the ambiance name because in the Chinese official translation the Silent profile is localized and the icon works with that translation.

martonmiklos ( 2016-10-13 14:40:09 +0200 )edit
2

If I think well the ContextKit's pulls the profile information from DBUS. At least this plugin does that: https://github.com/nemomobile/contextkit-nemo

I can see "general" and "silent" messages going on DBUS with Hungarian language, so it must be a problem in the contextkit plugin.

martonmiklos ( 2016-10-13 19:43:42 +0200 )edit
1

answered 2016-10-13 13:15:36 +0200

nthn gravatar image

Actually here's another report which might be related: https://together.jolla.com/question/95801/bugsilence-sounds-indicator-doesnt-show/

edit flag offensive delete publish link more

Question tools

Follow
2 followers

Stats

Asked: 2016-10-12 23:58:56 +0200

Seen: 297 times

Last updated: Oct 21 '16