Ask / Submit
10

m4a (AAC) Tracks not tracked correctly

asked 2016-10-19 18:36:55 +0200

njeiseck gravatar image

updated 2016-11-11 07:45:43 +0200

DarkTuring gravatar image

I've got a few iTunes encoded AAC files on both my SD card and also the internal storage. Those files are not correctly recognized by the media tracker.

The tracks do not appear in the Media player application but - with a "missing thumbnail" icon - in the Gallery/Video section. It is also possible to play those files from within the Gallery application.

Rebuilding tracker database does not help.

Is anybody else having this problem? Can I activate some debugging logs?

There's a similar question https://together.jolla.com/question/133985/flac-and-m4a-listed-under-videos-in-gallery/ describing the gallery thing but not the missing tracks in the media player.

SF OS Version 2.0.4.14.

edit retag flag offensive close delete

Comments

There's also stuff about m4a files in the comments to tbis question.

DaveRo ( 2016-10-19 19:20:21 +0200 )edit

Well, I don't have the mentioned MTP problems (don't use that). The files are already on the phone's file system.

njeiseck ( 2016-10-19 20:51:58 +0200 )edit

@njeiseck There are comments about playing the files too - nothing to do with MTP.

DaveRo ( 2016-10-19 22:34:26 +0200 )edit

@njeiseck I have played around a little more with the media application and can get all m4a songs recognized on external SD card, the problem is it doesnt read m4a tags correctly so even thought artist, album title, album artist, song title are properly identified only mp3 albums will be correctly listed in albums and artists, for m4a all artists remain unknown. This is a bug, Flowplayer from warehouse works well with m4a files so i am not bothering anymore right now with the Media Player.

DarkTuring ( 2016-11-11 07:45:14 +0200 )edit
1

@DarkTuring Thanks for mentioning FlowPlayer. This application correctly reads the m4a tags for me as well. So I guess there's actually a problem in the tracker's metadata extraction.

njeiseck ( 2016-11-11 10:53:16 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2016-10-28 06:42:24 +0200

DarkTuring gravatar image

updated 2016-10-28 07:00:15 +0200

Ditto that here is a solution that worked for me for the exact same problem:

  1. download Tracker Path Settings,

Tracker Path Settings Patch

  1. add ignored list the music folder with your m4a files (on nemo built in memory for example),
  2. add recursive tracker destination for music to your external drive music folder,

I have no idea why that actually works but added Videos and Images now properly show in gallery with no more video blank thumbnails.

Exclude Internal Nemo Music Include External Recursive Music

For good measures i include the empty folder ".music" in my on device /nemo/music/ directory and the music is found properly. I use QuasarMX Pro because it can handle the folder within folder structure created by iTunes and properly shows albums, songs and album art. Worth the $6.

edit flag offensive delete publish link more
Login/Signup to Answer

Question tools

Follow
1 follower

Stats

Asked: 2016-10-19 18:36:55 +0200

Seen: 201 times

Last updated: Oct 28 '16