Ask / Submit
5

Mobile data is not working after latest update version 2.0.4.14 Fiskarsinjoki [answered]

asked 2016-11-01 11:30:49 +0300

Maria83 gravatar image

updated 2016-11-01 11:46:50 +0300

sifartech gravatar image

After updating my jolla phone onto the latest update version 2.0.4.14 Fiskarsinjoki, my mobile internet stopped working. I tried to reset the mobile internet settings or inserting another sim card, but nothing worked. the button where you can turn on or off the mobile internet in the settings as well as in the shortcuts does not show any reaction.

What can I do?

Thanks for any advices.

Maria

edit retag flag offensive reopen delete

The question has been closed for the following reason "the question is answered, an answer was accepted" by pawel
close date 2016-11-03 07:39:17.845156

Comments

Check out the mobile data related issues section in Jolla phone: Troubleshooting phone call, SMS & mobile data issues.

sifartech ( 2016-11-01 11:48:45 +0300 )edit

Try switching on the wifi and switching it off

dillihifi ( 2016-11-01 13:14:19 +0300 )edit

had the same problem on J1, I only managed to fix it with a factory reset.

magullo ( 2016-11-02 06:58:44 +0300 )edit

2 Answers

Sort by » oldest newest most voted
8

answered 2016-11-02 22:50:59 +0300

smiddy gravatar image

A deletion of the ofono service can help here:

devel-su
systemctl stop ofono.service
cd /var/lib
mv ofono ofono.backup
mkdir ofono
chown radio.radio ofono
systemctl start ofono.service

(credits to cy8aer)

edit flag offensive delete publish link more

Comments

1

we tried this and it worked. Thanks for all good suggestions.

Maria83 ( 2016-11-02 23:07:04 +0300 )edit

This worked for me as well for getting the mobile data working. In addition I had to change the Access point name from the default settings to online.telia.se for the operator Telia here in Sweden. Thanks @cy8aer!

droid001 ( 2016-11-04 21:28:04 +0300 )edit

Solved my problem with grayed out mobile data switch, which appeared when I changed my operator. Many thanks! :)

pilq ( 2016-12-19 02:41:59 +0300 )edit
4

answered 2016-11-01 21:39:44 +0300

fennekki gravatar image

updated 2016-11-01 21:41:00 +0300

I recently had this same issue on my original Jolla, and managed to fix it.

First, a friend who was on Jolla C suggested they could fix it by toggling between the two SIMs in the device, and there's an app called "Ofono Log" on openrepos that had a button to, quite literally, "Fix Mobile Data" in its upper pulley menu, which solved my problem.

Specifically, the button in the Ofono Log application seemed to reset something related to which SIM is used for mobile data. Presumably the issue is related to the system somehow not picking the correct SIM even though there only is one SIM.

Edit: actually, seems like https://together.jolla.com/question/150137/mobile-data-not-working-after-switching-sim-card/ solves the same problem

edit flag offensive delete publish link more

Question tools

Follow
2 followers

Stats

Asked: 2016-11-01 11:30:49 +0300

Seen: 618 times

Last updated: Nov 02 '16