Ask / Submit
1

The "warehouse" application does not "see" my repos from "/etc/ssu/ssu.ini" [answered]

asked 2016-11-05 16:25:56 +0300

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

updated 2017-04-22 00:40:19 +0300

olf gravatar image

Hi,

I'm using SailfishOS 2.0.4.14.

I have more than 80 openrepos in my "/etc/ssu/ssu.ini" but the "warehouse" application "sees" only eight.

My "/etc/ssu/ssu.ini" :

[General]
arch=armv7hl
configVersion=12
credentials-scope=jolla
credentials-ttl=1800
credentials-url-jolla=https://download.jollamobile.com
credentials-url-store=https://store-repository.jolla.com
default-rnd-domain=jolla
deviceMode=4
disabled-repos=@Invalid()
domain=sales
enabled-repos=store
flavour=release
home-url=https://dav.jollamobile.com/dav/home/%1/
registered=false
release=2.0.4.14
rndRelease=latest

[credentials-store]
password=xxxxxxxxxxxxxxxxxxxxxxxxxxxx
username=sebmansfeld

[repository-urls]
Acce=http://sailfish.openrepos.net/Acce/personal/main
BloodyFoxy=http://sailfish.openrepos.net/BloodyFoxy/personal/main
CepiPerez=http://sailfish.openrepos.net/CepiPerez/personal/main
.....................................................................................
.....................................................................................

Can you anyone help ?

edit retag flag offensive reopen delete

The question has been closed for the following reason "the question is answered, an answer was accepted" by nthn
close date 2017-04-21 14:39:10.349128

Comments

1

@SebM first, please only use the how-to tag for giving instructions yourself.

about your problem: please post your ssu.ini here

misc11 ( 2016-11-06 01:16:18 +0300 )edit

@SebM well you cut the list of repos and pissibly disabled repos... try to fix that

also: the line "invalid-repos" is not like mine,but maybe thats just fine...

misc11 ( 2016-11-07 04:22:14 +0300 )edit

@misc11 I didn't list all my repos on purpose. In my /etc/ssu/ssu.ini my repo list is NOT cut, they are all there. I noticed the "invalid-repos" so I deleted this line, but it didn't solve my problem. Any other idea ?

SebM ( 2016-11-10 00:29:41 +0300 )edit

1 Answer

Sort by » oldest newest most voted
2

answered 2017-04-21 09:30:16 +0300

SebM gravatar image

updated 2017-04-21 09:31:16 +0300

I found out the reason why :

The repos I created with the following have the wrong name, they must contain the string "openrepos-" :

$ ssu addrepo $repo http://sailfish.openrepos.net/$repo/personal/main

The right command for the warehouse application to see them is :

$ ssu addrepo openrepos-$repo http://sailfish.openrepos.net/$repo/personal/main

Now my ssu.ini contains :

$ grep http://sailfish.openrepos.net/.*/personal/main /etc/ssu/ssu.ini
openrepos-Acce=http://sailfish.openrepos.net/Acce/personal/main
openrepos-BloodyFoxy=http://sailfish.openrepos.net/BloodyFoxy/personal/main    
openrepos-CepiPerez=http://sailfish.openrepos.net/CepiPerez/personal/main
............................................................
edit flag offensive delete publish link more

Question tools

Follow
1 follower

Stats

Asked: 2016-11-05 16:25:56 +0300

Seen: 352 times

Last updated: Apr 21