Ask / Submit
7

Sailfish Update to V 2.0.4.14 failed [resolved] [answered]

asked 2016-11-06 12:05:32 +0300

ukd192 gravatar image

updated 2016-11-06 20:48:19 +0300

The Phone sees the update 2.0.4.14 But after a few seconds banner appears with

" Problem with Store. Could not determine Size of Update."

Proceed to download and the download hangs. Have rebooted phone and tried via 4G and WiFi, still hangs. All Apps have connectivity so its not a connection issue, looks the the repository has issues. No Apps waiting to be updated and no none-Jolla Apps installed. Current version is 2.0.2.51 Any resolution or fix ? Thanks

edit retag flag offensive reopen delete

The question has been closed for the following reason "the question is answered, an answer was accepted" by vision
close date 2016-11-28 13:31:31.359429

Comments

1

Duplicate question https://together.jolla.com/question/148840/bug-20414-upgrade-fails/

Have a look and see if any apps are wanting to be updated in jolla store - assuming you can access it of course, then once any updates are done, try the update process again. Check out some of the comments on the link above.

Edz ( 2016-11-06 12:18:12 +0300 )edit
1

I seem to have the same problem as ukd192. I don't think it's the same problem fmotl linked to. Here are some lines from the journal:

    Nov 06 12:56:57 Sailfish ate-check[3190]: [D] PackageHandler::slotOsUpdateSizeFailure:637 - void PackageHandler::slotOsUpdateSizeFailure(const QString&) "Authentication failed (is SSU set up correctly?)"
Nov 06 12:56:57 Sailfish lipstick[986]: [D] displayNotification:311 - Warning: Notification has both preview summary and preview body but no actions. Remove the preview body or add an action: Store x-jolla.store.error Problem with Store Could not determine size of update
Nov 06 12:56:57 Sailfish ate-check[3190]: [D] Package::RepositoryTransactionPkgKit::slotWrappedTransactionFailure:306 - Wrapped transaction failed: "Authentication failed (is SSU set up correctly?)"
Nov 06 12:56:57 Sailfish ate-check[3190]: [D] Package::RepositoryTransactionPkgKit::restoreNext:128 - enabling "store"
Nov 06 12:56:57 Sailfish ate-check[3190]: [D] Package::RepositoryTransactionPkgKit::restoreSsuVersion:246 - Resetting ssu version
Nov 06 12:56:57 Sailfish ate-check[3190]: [D] Package::RepositoryTransactionPkgKit::setSsuVersion:211 - void Package::RepositoryTransactionPkgKit::setSsuVersion(const QString&) new version "2.0.4.13" current version "2.0.4.14"
Nov 06 12:56:57 Sailfish ate-check[3190]: [D] Package::RepositoryTransactionPkgKit::setSsuVersion:216 - changing SSU release: "2.0.4.13"
mattikbk ( 2016-11-06 13:00:52 +0300 )edit
1

All Apps are up to date, there is nothing waiting or in the process of updating. I only get the "Problem with Store. Could not determine Size of Update", when I try to update Sailfish. As a test I have installed two other apps . . no issues, just the Sailfish update.

ukd192 ( 2016-11-06 13:33:53 +0300 )edit
1

I can verify it happens for me to. This is not the same problem that fmotl refers to. There is an issue with the repository. To make sure, I did reset to factory state and gradually updated the OS. Everything up to 2.0.2.51 installs just fine -- using either GUI or terminal. The problem is specific to 2.0.4.14 (haven't tried 2.0.4.13 though, have to do that next). If you try to install via terminal, you can see how all the responses from the repository fail. Dave999 reports the same problem on TMO. ..... Just tried 2.0.4.13, doesn't work either.

jtkleine ( 2016-11-06 14:06:40 +0300 )edit

Sign me up for this issue, too!

Still on 2.0.1.11 and waiting impatiently for working fiskars download.

Dave999 ( 2016-11-06 15:18:50 +0300 )edit

2 Answers

Sort by » oldest newest most voted
15

answered 2016-11-06 20:38:42 +0300

Keto gravatar image

There was an issue on the repository server, but that has now been fixed, and downloading the 2.0.4.14 update should work again.

edit flag offensive delete publish link more

Comments

I can confirm that in my case it now works again.

hepheistos5585 ( 2016-11-06 20:45:46 +0300 )edit
1

I can confirm that the download completed and the update has been successful. Thank you very much for the quick fix.

ukd192 ( 2016-11-06 20:47:24 +0300 )edit

Having this same problem currently (yesterday 31st of December and today 1st of January) with store. Should the repository server be all right?

Karri Huhtanen ( 2018-01-01 11:51:29 +0300 )edit
0

answered 2016-11-28 13:07:12 +0300

vision gravatar image

Hello,

not sure whether my problem is related to this problem. During the last weeks I was concentrating more on updating the Jolla C, Jolla tablet and Intex Aqua Fish. Today I thought... hey, I need to update my Jolla 1 phones as well and while trying that I got as well the error:

" Problem with Store. Could not determine Size of Update."

Restoring the app-registry doesn't help and a "pkcon refresh" as root gives me the following error: *"Fatal error" - SSL certificate problem: certificate is not yet valid.*

The JP1's are on 2.0.2.51 and I want to go for 2.0.4.14

Any help appreciated ;). Couldn't find this error via search TJC search function. Thanks, vision

edit flag offensive delete publish link more

Comments

The time and date on you device are probably not correct. That's why it thinks the SSL certificate is from future.

Keto ( 2016-11-28 13:18:00 +0300 )edit

Aaargh... you are right... Thanks for the hint ;). Downloading now...

vision ( 2016-11-28 13:30:39 +0300 )edit

Question tools

Follow
1 follower

Stats

Asked: 2016-11-06 12:05:32 +0300

Seen: 1,309 times

Last updated: Nov 28 '16