Ask / Submit
1

Several problems with Jolla1 with os-uppgrade and store

asked 2016-11-09 19:29:47 +0200

Jore gravatar image

updated 2016-11-10 17:33:38 +0200

jovirkku gravatar image

I noticed my problems when the Fiskarsinjoki uppdate was released for everyone. I started the optimization process and i think it went fine but I didn't start the installation because I wanted to do a backup.

The backup process wont start - I only get a notification that "settings won't answer". I can either wait or quit. If I wait I get the same notification after few seconds. I've tried this several times.

Another problem is that I can't activate developer mode. The activating prosess starts but won't finish. I get a notification that the developersmode can't be found in Jolla store. I've tried several times wiht both wifi an 3G and even though the connection otherweise work well. This doesn't work. I have installed other apps from store during this time with these problems.

I've noticed these questions and answers (https://together.jolla.com/question/150635/sailfish-update-to-v-20414-failed-resolved/ and https://together.jolla.com/question/148840/bug-20414-upgrade-fails/) about the failing uppgrade but I haven't got so far that I could follow these answers.

I have booted the phone and restarted everything I can from the settings but i haven't reset the phone. I'm using 2.0.2.51 (Aurajoki) and I have 4,6 GB free space + an unused sdcard so there shouldn't be a problems with space either. I have some apps installed from openrepos.

I'm no programmer so I would need were clear instructions to get my Jolla fixed.

edit retag flag offensive close delete

Comments

1

check btrfs allocation. if you cant do it with terminal, cause you said dev mode.cant be enabled.. u can use schturmans btrfs tool from open repos. i had several times problems with turning on dev mode. reboot and try again

pawel ( 2016-11-09 20:27:13 +0200 )edit

Thanks for a quick answer. I can't get to terminal without developers mode. Tried this btrfs from open repos but I'm not sure if it worns correctly. I don't get any respons after a check. Should I get an respons if everything i fine.

The bttfs cixed my problems earlier with the Aurajoki uppgrade but then I could activate developers mode and got some good instructions.

Jore ( 2016-11-13 09:15:07 +0200 )edit

I couldn't solve the problems i had but I survived with my phone. But when it was time to update to 2.1. i decided to take a chance and restore factory settings. Everything went well an I could update my phone but now I can't access developers mode. When I activated it it didn't ask me to give a password and it doesn't accept my old password. (I get Auth. failed)

Otherwise the phone works well but I can't install some apps - like Meerun - or patches.

If I understand correct I should get to pkcon refresh. But now I'm not able to access developers mode. Any hints, what I should try next?

Jore ( 2017-06-07 12:35:28 +0200 )edit

2 Answers

Sort by » oldest newest most voted
5

answered 2016-11-09 22:43:44 +0200

Keto gravatar image

The backup from system update screen getting stuck on 2.0.2.51 is a known issue. You need to reboot the device and then you can make backup from Settings > Backup. After that you should be able to start the system update normally from Settings > Sailfish OS updates.

For the failing developer mode activation I could not find any clear reason on our backends at the moment.

If the system update still does not work, or enabling the developer mode still does not work after the system update, then let me know.

edit flag offensive delete publish link more

Comments

The issue with taking a backup from the OS update dialog was fixed to 2.0.4 release. Hence it should not be a problem any more when downloading the next update (if the device has 2.0.4 at that point of time).

jovirkku ( 2016-11-10 17:39:48 +0200 )edit

I still have the same problems. If I start the backup from settings -> backup I only get a notification that settings wont answer and I can eithet chose wait or quit. If I chose wait I get the same notification again after a few seconds.

If I try to activate developers mode I get a notification that developers mlde can't be found in store.

Haven't tried to uppgrade before I get an backup. Earlier I've done that and I think that the backup from settings haven't work then either.

Jore ( 2016-11-13 09:33:34 +0200 )edit
1

answered 2016-11-10 01:28:44 +0200

azupan gravatar image

updated 2016-11-10 01:29:18 +0200

I updated my Jolla Phone with developer mode enabled.

I've just tried to disable it, and enable it again. Re-enabling got stuck at about 20%. I've interrupted it by right swipe, and retried. Now it works OK. Hope this helps.

edit flag offensive delete publish link more
Login/Signup to Answer

Question tools

Follow
2 followers

Stats

Asked: 2016-11-09 19:29:47 +0200

Seen: 360 times

Last updated: Nov 10 '16