Ask / Submit
23

How to stop auto download of sailfish browser

asked 2016-11-21 02:21:05 +0200

fishegg gravatar image

updated 2017-04-06 05:02:35 +0200

Last time I used Browser to download a file. And before it finished I closed Browser. Download was done. Now every time I open Browser, download remorse timer pops up and tells me it is going to download. Clean data from Settings can not help.

Transfer page. All items on the page are same. That's what Browser downloaded every time it was opened. image description

Edited 2016.11.22 modified topic and text. Edited 2016.11.24 added screenshot. Edited 2017.3.14 still in 2.1.0.9 Edited 2017.4.6 still in 2.1.0.11

edit retag flag offensive close delete

Comments

Close the tab which initiates the download.

Sthocs ( 2016-11-21 12:32:55 +0200 )edit

@Sthocs Did not work. I select close all tab when exit in Settings and nothing happened.

fishegg ( 2016-11-22 00:13:49 +0200 )edit

I added the bug tag, since if you tried to clear the browser content from Settings and closed all open tabs, this shouldn't happen.

raketti ( 2016-11-22 09:05:33 +0200 )edit

I think it's a bug as well. Had the same experience. Only solution I found to stop it was to completely download another file. Did this happen on 2.0.5 or 2.0.4?

It has nothing to do with open tabs or active transfers in settings.

alain ( 2016-11-23 12:20:51 +0200 )edit
1

@caprico both.

fishegg ( 2016-11-28 04:49:29 +0200 )edit

2 Answers

Sort by » oldest newest most voted
8

answered 2017-01-03 21:46:21 +0200

alain gravatar image

updated 2017-01-03 21:51:38 +0200

I could fix the problem by deleting the whole /home/nemo/.mozilla folder, which is regenerated when reopening browser. Unfortunately I couldn't find out which file in .mozilla/mozembed was causing the bug.

Following attemps I tried didn't help:

  • delete & reinstall browser
  • clear private data in settings
  • re-download exact same file

I hope Jolla will look into fixing this bug - please upvote this bug report.

edit flag offensive delete publish link more

Comments

1

Can confirm, works for me too. Thanks!

attah ( 2017-01-03 21:51:41 +0200 )edit

redownload should work, but you may try many times

fishegg ( 2017-01-05 06:01:37 +0200 )edit

@fishegg: The first time i had this problem, redownload worked - not the 2nd time though. And redownloading a >1GB .iso file isn't that much fun :-)

alain ( 2017-01-05 17:15:24 +0200 )edit

you're right. hope jolla can solve it soon.

fishegg ( 2017-01-07 09:03:23 +0200 )edit
9

downloads.json is the file where downloading (or downloaded files) are stored. Just remove it - it worked on my phone :-)

Alessandro ( 2017-01-22 13:13:54 +0200 )edit
0

answered 2016-11-21 08:46:38 +0200

coderus gravatar image

Open Settings - Transfers and stop download here.

edit flag offensive delete publish link more

Comments

Not the same thing. Maybe I did not have a clear description. Every time I open Browser it automatically downloads a file which was downloaded by me. Now Transfers page is full of same items.

fishegg ( 2016-11-22 00:19:20 +0200 )edit

why it doing so? do you have tons of tabs opened?

coderus ( 2016-11-22 10:53:18 +0200 )edit

No, I closed all tabs but it still started download.

fishegg ( 2016-11-22 18:15:46 +0200 )edit
1

It start downloading right after you starting browser? Check your homepage settings.

coderus ( 2016-11-22 18:28:43 +0200 )edit
1

Exactly. Homepage is cn.bing.com.

fishegg ( 2016-11-23 04:02:53 +0200 )edit
Login/Signup to Answer

Question tools

Follow
3 followers

Stats

Asked: 2016-11-21 02:21:05 +0200

Seen: 1,014 times

Last updated: Apr 06