Ask / Submit
2

[bug]Jolla C Dual Sim Lack of Signal with Data Only Sim [answered]

asked 2016-11-22 14:40:58 +0300

r0kk3rz gravatar image

updated 2016-11-22 15:45:59 +0300

My situation is as follows, I have two SIM cards in my Jolla C, one is SIM1(Three): calls/text/4g and the other is SIM2(EE): 4g data only, Country: United Kingdom.

When I have SIM1 for calls and text, and SIM2 for mobile network, the signal for calls and text seems to be zero most of the time, even in areas I know good signal exists, however mobile network is connected and active.

If i have SIM1 for calls/text/data enabled, the display has both SIMs showing very good signal.

Is this the expected behavior? I was hoping that I could be contactable through the calls/text sim whilst having the data only sim active.

I have seen this since 2.0.2 - currently on 2.0.5

EDIT: New information.

For SIM1, i turned off 'automatically select network' as it appeared to be in state 'searching', upon selecting the right network it thinks for a while then says 'oops something went wrong' in notification, and the network state says 'DENIED'

edit retag flag offensive reopen delete

The question has been closed for the following reason "the question is answered, an answer was accepted" by r0kk3rz
close date 2016-11-22 17:59:55.577867

2 Answers

Sort by » oldest newest most voted
2

answered 2016-11-22 15:21:22 +0300

slava gravatar image

When you select SIM2 for data, two things happen in ofono:

  1. Data is enabled for SIM2 (and consequently disabled for SIM1)
  2. 4G is getting set as the preferred network mode for SIM2 (because only one SIM at a time can use 4G)

First I would try to set the network mode preference for SIM1 to 3G and see what happens. That would eliminate step 2. If step 1 still kills SIM1, I would try swapping the SIM cards. If that still doesn't help... then something funny must be going on in the modem which makes this particular combination of SIM cards to behave like this.

edit flag offensive delete publish link more

Comments

just to be clear, sometimes SIM1 gets signal (although weak) in my preferred configuration, so it could be interference of some kind

r0kk3rz ( 2016-11-22 15:38:49 +0300 )edit

Ok, I just went through a few combinations of setting the preferred network mode and it doesn't seem to be having any effect so far, but i'll leave it a little while and check on it

r0kk3rz ( 2016-11-22 15:41:34 +0300 )edit

aha! i think I see the problem, the three mobile sim doesn't do 2g at all. I wonder if its a technology preference settings issue when on calls/sms only

r0kk3rz ( 2016-11-22 16:20:40 +0300 )edit
1

answered 2016-11-22 16:50:56 +0300

r0kk3rz gravatar image

Self answer but just in case anyone else trips up over this:

The issue is a Technology Clash, on the Jolla C (and probably Intex Aqua Fish) it seems only one SIM can use any given technology class at a time (2g/3g/4g).

Three Mobile in their wisdom have decided to remove their 2g network, and as such requires at minimum 3g in order to connect at all. The EE SIM due to my location only gets 3g connectivity, hence the clash.

If I force the EE SIM to use 2g only (pointless, but for testing), the Three SIM connects just fine.

edit flag offensive delete publish link more

Comments

3

That explains it. Actually, GSM (2G) can be used by both slots simultaneously, but 3G/LTE only by one slot at a time. That seems to be a hardware limitation.

slava ( 2016-11-22 17:13:57 +0300 )edit

@slava thanks for the confirmation

r0kk3rz ( 2016-11-23 14:43:37 +0300 )edit

Question tools

Follow
2 followers

Stats

Asked: 2016-11-22 14:40:58 +0300

Seen: 235 times

Last updated: Nov 22 '16