We have moved to a new Sailfish OS Forum. Please start new discussions there.

usb0 disconnections on Ubuntu because of the NetworkManager

asked 2016-12-06 10:35:36 +0300

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

updated 2019-10-29 03:29:16 +0300

SebM gravatar image


When I connect to my Jolla through ssh over USB from my Ubuntu, I often get disconnected :

$ ifconfig usb0 | grep inet.addr
$ route -n | grep usb0

EDIT : I've finally set usb0 ip address manually :

$ sudo ip address add dev usb0
$ ifconfig usb0 | grep inet.addr
          inet addr:  Bcast:  Mask:
$ ssh nemo@
nemo@'s password: 
X11 forwarding request failed on channel 0
Last login: Tue Oct 29 01:05:35 2019 from
| SailfishOS (Ohijärvi) (armv7hl)
[nemo@localhost ~]$

Can anyone help me solve this problem ?

edit retag flag offensive close delete


I often got the same problem (usb reconnects) when moving the phone, I guess it's a mechanical problem due to the usb port/plug not being very reliable

till ( 2016-12-06 11:41:10 +0300 )edit

@till I am NOT moving the phone and my USB does NOT have "reconnects" BUT "disconnects" problems so I guess it is not a mechanical problem

SebM ( 2016-12-06 12:11:58 +0300 )edit

is it related to the phone's screen switchting off? if so, power management might kick in and slow the phone down

till ( 2016-12-06 12:40:17 +0300 )edit

Could be something funny going on with your network manager in Ubuntu.

Check /var/log/syslog

juiceme ( 2016-12-06 13:11:33 +0300 )edit

2 Answers

Sort by » oldest newest most voted

answered 2016-12-09 16:48:29 +0300

Philippe De Swert gravatar image

If you're on Ubuntu and using network manager then this can happen to you. For some reason sometimes network manager just pulls the interface down. You can avoid this by explicitly making this a configured interface in network manager. Or don't use network manager, or tell network manager to ignore the interface and config it by hand.

edit flag offensive delete publish link more

answered 2018-11-27 16:05:27 +0300

pemek gravatar image

Necromancy warning!

Today I resolved this issue (it was HW based as my uUSB connector is little damaged) with adding NetworkManager entry for wired connection: I have used "Device" fixed to enp0s29u1u1 (in my case, but it may vary on physical location of USB cable) and set "Cloned MAC address" to fixed value (eg. 00:11:22:33:44:55). After reconnection, ssh session is reestablished.

edit flag offensive delete publish link more
Login/Signup to Answer

Question tools



Asked: 2016-12-06 10:35:36 +0300

Seen: 295 times

Last updated: Oct 29 '19