Sony Xperia Pro - SIM not detected

asked 2017-01-16 22:55:31 +0200

haem gravatar image

updated 2017-01-30 15:52:42 +0200

jiit gravatar image

Hello.

I've followed instructions from these two tutorials: link link

No problems installing and booting, camera is not working, in the second link the author indicates a FIX, but zypper in --from iyokan harbour-cameraplus seems not valid anymore, the repo, the package is no more.

I like the OS, very new to me, store working, did not test everything yet.

My main problem is that my SIM does not work with, therefore I cannot use the phone as suposed. I'm from Portugal, using NOS, tried several cards, in other devices, firefox OS and Android the card works, even my chinese watch, but not with Sailfish.

If someone can give me some advice how to fix this I will be very appreciated.

Update:

journalctl -fa > create_ril: can't connect to RILD: No such file or directory (2)

zypper update > The following package updates will NOT be installed: droid-config-iyokan droid-config-iyokan-sailfish ofono pulseaudio-modules-droid pulseaudio-modules-droid-common

I've read the forum in a previous post that ofono might have some influence in the SIM card problems but I'm not sure.

edit retag flag offensive close delete

Comments

woot! Xperia 10 Mini Pro is supported now - cool :)

hoschi ( 2017-01-17 12:34:21 +0200 )edit

Hello ! You can have a look at the Cellular Telephony Architecture of sailfishOs at https://sailfishos.org/wiki/Cellular_Telephony_Architecture Indeed, ofono seems mandatory.

phklrz ( 2017-01-17 13:25:19 +0200 )edit