Ask / Submit
6

Qt5.7 and Sailfish [answered]

asked 2017-01-31 14:51:24 +0300

arminfelder gravatar image

updated 2017-01-31 16:48:05 +0300

Alex gravatar image

Hello, I am creating an app for android and iOS using Qt5.7, and I was wondering if it would be possible to port it to Sailfish as well... My problem is that I use QtQuickControls2 a lot, and therefor need Qt5.7, but the SDK only gives me 5.5. Is there any way to get 5.7 on my device?

edit retag flag offensive reopen delete

The question has been closed for the following reason "the question is answered, an answer was accepted" by molan
close date 2018-05-01 15:28:52.141465

1 Answer

Sort by » oldest newest most voted
12

answered 2017-01-31 15:37:16 +0300

balta gravatar image

The next update (SailfishOS 2.1) will be based on Qt 5.6, so I do not think there will be an update to 5.7 anytime soon.

QtQuickControls are completely missing anyway as they do not provide the same type of UI SailfishOS apps are using.

edit flag offensive delete publish link more

Comments

2

In addition to this, 5.6 is a Long Term Support release, so it makes sense to stick with this for a while until the next LTS of Qt.

pigg ( 2017-02-01 21:28:09 +0300 )edit

Question tools

Follow
3 followers

Stats

Asked: 2017-01-31 14:51:24 +0300

Seen: 793 times

Last updated: Jan 31 '17