Ask / Submit
1

[bug][test] 2.1.0.9 Browser text selection: Does search button work? [answered]

asked 2017-02-08 20:07:46 +0200

cy8aer gravatar image

updated 2017-02-08 20:22:30 +0200

Browser:

  • select some text
  • a search button occurs
  • clicking this button -> tab opens with your favorite search engine

expected:

  • text is in the search field of the search engine and search starts

actual behaviour:

  • search field is empty

I use an own searx-engine with it's own searchengine file. Eventually this is the problem, but...

Sharing button works.

edit retag flag offensive reopen delete

The question has been closed for the following reason "the question is answered, an answer was accepted" by jiit
close date 2017-02-13 16:40:58.996924

Comments

1

Works for me as expected, searches with selected text.

pekkeli81 ( 2017-02-08 20:27:15 +0200 )edit

Works for me as well, using Duckduckgo search engine.

EDIT: Just tried it with searx. No problem at all. I used this package to add more search engines in case you want to try it out:https://openrepos.net/content/coderus/search-engines-sailfish-browser

molan ( 2017-02-08 21:13:05 +0200 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2017-02-08 22:02:22 +0200

cy8aer gravatar image

updated 2017-02-08 22:04:00 +0200

Ah found it. My definition (as imported from my searx server!!) looks like this

<os:Url type="text/html" method="POST" template="https://my.si.te/" resultDomain="my.si.te">
     <os:Param name="q" value="{searchTerms}"/>
     </os:Url><os:Url type="application/x-suggestions+json" method="GET" template="https://my.si.te/autocompleter" resultDomain="my.si.te">
     <os:Param name="format" value="x-suggestions"/>
     <os:Param name="q" value="{searchTerms}"/>
</os:Url>

So this is a POST. I changed it to GET and it works.

POST definitions do not work!

edit flag offensive delete publish link more

Question tools

Follow
1 follower

Stats

Asked: 2017-02-08 20:07:46 +0200

Seen: 201 times

Last updated: Feb 08 '17