2.1.0 OpenConnect usage

asked 2017-02-09 09:57:59 +0200

mattikbk gravatar image

updated 2018-06-06 13:14:10 +0200

I tried to test the new VPN settings using an OpenConnect service. I'm confused about the settings though. What am I supposed to put in fields "WebVPN cookie data", "Server certificate hash" or "Server after authentication"? When I use OpenConnect on my Linux laptop, I must give the server name, username, usergroup and password.

edit retag flag offensive close delete

Comments

3

Also how can you specify command line options to pass into OpenConnect?

coley ( 2017-02-09 12:25:08 +0200 )edit
1

You would need to do the authentication in command line then you would get server hash, cookie data and server address. Though those values are only valid once, so me too I am wondering how they thought one would use openconnect.

ausgeregelt ( 2017-02-09 21:32:12 +0200 )edit
2

Yeah, surely those values should be auto-retrieved? The Windows client also only needs the same values as mentioned above.

vitaminj ( 2017-02-11 13:57:01 +0200 )edit
1

This issue still stands in 2.2.0.29 despite VPN support being "Out of beta stage now" per release notes

mattikbk ( 2018-06-06 13:15:26 +0200 )edit