Ask / Submit
6

My internet setting says it's "disabled" yet I have 3G coverage

asked 2014-01-16 11:42:22 +0300

westy gravatar image

updated 2014-01-16 11:49:37 +0300

I've switched off wireless and selected mobile network connection Data roaming is "Always allow" The indicator shows that I have got a 3G signal

But when I try to open a browser I get the red connection message to connect to wireless - the networks around me aren't open(!) so I refuse that and guess what - yup - it keeps asking me to select the wireless internet connection!

I have to reboot the phone to get it to work - which is really stupid.

Here's a natural scenario many of you will face.

I'm at home, it's time to go to work so I leave my house and get in my car. I put my phone in it's docking clamp and start up my navigation app (Waze) - it recognises that I'm probably off to work and asks me this - I confirm and it presents me with the route and I click to start.

Within a few yards I'm outside the reach of my home wireless network so the device starts to look for the mobile data network - and it looks and it looks and it looks - and it never finds it.

I want to use a data connection - at home my default is wireless away it is mobile data - why won't my phone allow this switchover to happen automatically when there are no "known" wireless networks around??

edit retag flag offensive close delete

Comments

Well i could help myself by factory resetting and at the same time another solution was also provided by the site provided here : Mobile Data Disabled - Solved

Somesh Chaudhary ( 2016-05-14 23:31:15 +0300 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2014-01-16 11:48:00 +0300

torti17 gravatar image

Try this:

disable all networks, count till 10 sec. and enable only 3G/mobile connection. Then it should work.

edit flag offensive delete publish link more

Comments

1

I'll try that tomorrow morning - but it still doesn't do what my old Android Galaxy note did automatically so it isn't really an answer it's a workaround:(

westy ( 2014-01-16 11:50:53 +0300 )edit

OK I tried that and it didn't work. I had to use the Sailfish Reboot app to restart the phone and then it did recognise the mobile data connection - weird!

westy ( 2014-01-17 10:26:09 +0300 )edit

Have the same problem - have tried re-starting the handset, but mobile data is still showing as disabled.

gordio ( 2014-02-13 21:29:48 +0300 )edit

Hi, I am facing this issue often after upgrade to 1.1.1.27. It gets fixed on changing 2G / 3G preferences, enable and disable flight mode, restart n/w connections using Sailfish Utilities.

anandrkris ( 2015-02-03 10:51:18 +0300 )edit
Login/Signup to Answer

Question tools

Follow
1 follower

Stats

Asked: 2014-01-16 11:42:22 +0300

Seen: 1,412 times

Last updated: Jan 16 '14