Ask / Submit
8

[bug?] Bluez5 - can't connect to audio profile (Jolla C v2.1.0.9) [released]

asked 2017-02-14 20:40:57 +0300

Schturman gravatar image

updated 2017-02-14 20:54:38 +0300

Hi to all. After system update I also upgraded bluez4 to bluez5. But I have a big problem with audio profile...
1. Fresh pairing with Mazda3 Car system - no problem
2. After few minutes - phone disconnected for some reasons... I checked the setting in the car and find that car system CAN'T connect to Audio+Phone profiles, it can connect only to Phone profile... (car have 3 options: Audio+Phone, Phone, Audio)

3. Removing pairing from phone and car and reinstalling Bluez4 + reboot.
4. New pairing and all work fine, car connected without any problem to both profiles (audio and phone).

I tested it twice, but on Bluez5 it still doesn't wants to connect to Audio profile.
Any idea why it not work and maybe some workaround how to fix it ?
Thanks

P.S. Another thing that I noticed, that Bluetooth icon not changed to white when connection is created, it stays grey...

edit retag flag offensive reopen delete

The question has been closed for the following reason "released in a software update" by harry
close date 2017-09-04 14:20:07.205963

Comments

1

The bluetooth indicator issue is already been worked on: bluetooth-indicator-not-working

raketti ( 2017-02-15 08:26:12 +0300 )edit

I have the same problem in my Opel Astra

balta ( 2017-02-15 12:22:17 +0300 )edit

I have a similar issue with a parrot ck1300 car kit not connecting/pairing properly with bluez5 installed

coley ( 2017-02-15 13:00:50 +0300 )edit
1

I have a similar issue with the CK3100. I can connect but no longer get the phonebook trrasferred, so looks like there is a problem with PBAP. This is already reported in another thread, but perhaps the priority needs raised? I have not used bluez5 at all.

pigg ( 2017-02-15 22:20:16 +0300 )edit

And there I was thinking the issue was to do with me messing with bluez5, I've the phonebook problem too.

coley ( 2017-02-15 23:30:14 +0300 )edit

1 Answer

Sort by » oldest newest most voted
4

answered 2017-02-15 14:23:22 +0300

Andy Branson gravatar image

Bluez5 is available in 2.1.0 for developers to try out with their apps. The rest of Sailfish isn't completely ported over to it yet - it's still being worked on, so it's not really suitable for everyday use. Best to roll back to Bluez4 and wait for the next update.

edit flag offensive delete publish link more

Comments

Am well aware of that :) was just giving feedback. btw are the qt/qml portions of ble support anywhere near available in the same way bluez5 is?

thanks

coley ( 2017-02-15 14:57:49 +0300 )edit

My JP1301 on 2.1.0.9 with bluez4 does no longer automatically connect to my car stereo. Manually connecting (from the car, specifically selecting my Phone) works. But then, no telephony services are accessible from the car (phonebook, etc.) whereas dialling from the phone still works with full bluetooth audio support.

I see that my comments don't match this thread's subject, but I fear those problems do not relate to either bluez4 or bluez5, but a different component of Sailfish. What can I do about that? Opening a new thread, pointing to bluez4?

Maus ( 2017-02-24 10:34:25 +0300 )edit

Did you tried to remove pairing from phone and car system and repair it again ? For me with bluez4 all work like before system update (phonebook, calls, audio..)

Schturman ( 2017-02-24 11:06:48 +0300 )edit

Thanks @schturman, re-pairing the device made it auto-connect again. The rest of my problems with 2.1.0.9 are discussed here: https://together.jolla.com/question/157193/phonebook-sync-with-car-does-not-work-anymore-since-v2109/

Maus ( 2017-02-25 12:34:17 +0300 )edit

Question tools

Follow
4 followers

Stats

Asked: 2017-02-14 20:40:57 +0300

Seen: 721 times

Last updated: Feb 15 '17