Ask / Submit
22

Two weeks with the new vpn

asked 2017-02-18 18:48:29 +0200

cy8aer gravatar image

updated 2017-02-23 09:11:44 +0200

I tried the new vpn stuff with my openvpn settings for some days when visiting a conference. I had the traveling by train (new german ICE WLAN + LTE box + device itself), two captive portal WLANs. All networks were pure v4.

I must say this worked quite good. Switching between the networks was fine most of the time. Somtimes the device did not reconnect the tunnel when switching. Sometimes a working tunnel was shown in status bar but nothing happened anymore (captive portal during the night).

Fortunately no exorbitant battery draining occured (was at about 50% at the end of the day).

edit retag flag offensive close delete

Comments

as question, what could be improved or optimized?

cemoi71 ( 2017-02-19 19:34:57 +0200 )edit

OpenVPN is working on Jolla since 2013. And is works good. The only new is the integration in settings. What should improved or optimize?

Battery drain depends from using the screen or from LTE. Not from this piece of software.

utkiek ( 2017-02-23 17:32:07 +0200 )edit

VPN doesnt work for me when importing open vpn no authorization files. TCP or Non-TCP no luck.

Says its connected but no tunnel, for me SecureFishnet is the only functionning VPN client still.

DarkTuring ( 2017-02-24 02:10:20 +0200 )edit

2 Answers

Sort by » oldest newest most voted
2

answered 2017-02-20 09:18:53 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

updated 2017-02-20 12:50:40 +0200

cy8aer gravatar image

(as an answer for cemoi71)

This should be improved: v6 support - as talked in https://together.jolla.com/question/156391/brainstorm-vpn-security-and-design-issues-long-post/

A very useful improvement would be a definition of home networks. Actual every connection builds up a tunnel with the automatic reconnect button. But this makes no sense in the home network. Better: I did not find any option to do this, probably there is a solution already??

Optimized: Because sometimes the tunnel is just disconnected (with or without statusbar icon shown) it would be nice to have some watchdog to re-enable the tunnel again. Works most of the time. I had this problem when leaving one hotel (wlan) crossing the street (lte) and entering another hotel (wlan). Then the tunnel sometimes was not re-enabled. Hopefully without any keepalive stuff over the network (because of battery draining!).

Bug? After building up the tunnel I have an additional entry "Connection to your.net". For me this entry does not work and can be deleted (but appears again...). Useless??

edit flag offensive delete publish link more
1

answered 2017-02-23 09:11:54 +0200

cy8aer gravatar image

updated 2017-02-23 23:19:28 +0200

The system seems to learn the home network: Since yesterday it disables vpn when entering my home network. But I am not able to find out what makes it learn.

[update] Did not work today. Probably it was only the "I do not reconnect now" bug.

edit flag offensive delete publish link more

Comments

1

<idea>Maybe you could use Situations app and shell scripts to achieve what you want? When on home network - service openvpn stop. When off home network - service openvpn start.</idea>

Just a quick thought over my morning coffee. ;)

eson ( 2017-02-24 08:01:35 +0200 )edit

As I understand the tunnel is started and stopped via connman's ovpn mimikry. This might or might not?? interfere with standard openvpn systemd start/stop calls. And: I do not use Situations :-(

cy8aer ( 2017-02-24 10:48:58 +0200 )edit

You are right, standard openvpn systemd start/stop calls do not work (now checked). Well, the idea is still an idea, only not with those parameters. ;)

eson ( 2017-02-24 11:04:44 +0200 )edit
Login/Signup to Answer

Question tools

Follow
3 followers

Stats

Asked: 2017-02-18 18:48:29 +0200

Seen: 1,357 times

Last updated: Feb 23 '17