Ask / Submit
16

[bug - fixed 2.1.0.10] 2.1.0.9 not able to save new event via CalDAV

Tracked by Jolla

asked 2017-02-22 09:31:59 +0300

cy8aer gravatar image

updated 2017-03-24 15:30:09 +0300

I am not able to save a new calender event via CalDAV:

  • create a new event
  • save it to your CalDAV-calender

Expected: event is saved directly to the CalDAV server without manually started sync.

Actual behaviour: event is not saved. Even re-syncing doesn't have an effect

When creating the event in some other connected calendar (lightning) the event is shown on the phone after syncing. This definitely worked with 2.0.x. Nextcloud 10.1 (alpine/docker)

edit retag flag offensive close delete

Comments

1

This is a much more general (and accurate) description of the whole problem than in previous reports about specific tools e.g. owncloud. Links between them would be good to show we know the relation. On the phone, so not pasted here directly.

ljo ( 2017-02-22 12:21:37 +0300 )edit

I have the exact same problem, with mailbox.org (which uses OpenExchange). Editing existing entries doesn't work either.

sigma_ ( 2017-02-22 18:09:23 +0300 )edit

I have exactly the same problem with owncloud. Editing / Deleting an existing event doesn't work either

argonius ( 2017-02-22 22:49:28 +0300 )edit
1

I have same issue with 2.1.0.9. New event is created locally and with syncing it disappears. Changes of existing events gets lost as the server version of the event is synced back to phone.

I use Caldav with Nextcloud 11.0.1.

Adding and editing of Exchange-events works as expected.

Alexander ( 2017-02-24 13:00:58 +0300 )edit

Thanks for the report, I will investigate.

chris.adams ( 2017-02-27 08:32:50 +0300 )edit

2 Answers

Sort by » oldest newest most voted
4

answered 2017-02-24 08:17:53 +0300

Nrsisti gravatar image

Reported the issue, thank you :)

edit flag offensive delete publish link more

Comments

I think that's a slightly different issue than this one, which appears to be related solely to upsync.

chris.adams ( 2017-02-27 08:32:36 +0300 )edit
1

After more investigation, I believe I was wrong and you were right: this is the same issue. The upsync is "failing" because the local modifications (additions, removals, or edits) are being thrown away due to the clean-sync semantics. I am now looking into this clean-sync issue in more detail.

chris.adams ( 2017-02-27 09:32:37 +0300 )edit
4

answered 2017-03-24 15:29:12 +0300

cy8aer gravatar image

2.1.0.10 - Bug fixed!

edit flag offensive delete publish link more
Login/Signup to Answer

Question tools

Follow
5 followers

Stats

Asked: 2017-02-22 09:31:59 +0300

Seen: 515 times

Last updated: Mar 24