Media missing on Android side gallery SFOS2.1.0.9

asked 2017-03-07 20:13:43 +0200

Sakke gravatar image

updated 2017-03-07 21:56:40 +0200

Hi all!

I couldn't find anything similar to this issue. After updating to Sailfish OS 2.1.0.9, I had no problems sharing pictures/media on Android apps like WhatsApp. I have over 7000 media on SDCard and I'm aware of the fact that indexing those media files can take a long time. However, the issue doesn't seem to be on indexing the files because native gallery app shows all the media normally. In my opinion there could be some kind of issue with Android side indexing etc.

I had this "missing" media problem first with screenshots but now it seems that sometimes even some of the media captured by native Sailfish camera can't be found on Android side gallery. For instance, some of the pictures that I have taken today can't be found on WhatsApp because they just simply don't exist on Android gallery. Right now I'm trying to refresh media database "Virkistä mediatietokanta" using Sailfish Utilities but to this far it has worked only occasionally. I have tried to reboot the phone (Jolla Phone 1) in order to get the media back but it doesn't help.

Also when it comes to the screenshots. They aren't available anymore. Before SFOS2.1.0.9 they were available on Android gallery with normal media like pictures. On 2.1.0.9 it seems that something have changed and those screenshots are missing.

I just would like to know whether this is a bug or what. I hope you got my point and I'll try to answer your questions as well as I can.

Edit: After running the refresh (media database) and restarting alien dalvik, it seems that everything is fine right now. However, the next question is when this is going to happen again.

edit retag flag offensive close delete

Comments

1

For me, it's the same.

wosrediinanatour ( 2017-03-07 21:45:44 +0200 )edit

i had a problem when i took several pics with a camera but half of them were available in android app, and half of them not. Turned out that order of pics were messed up. Even though the pics were made at the same time, some of them were at the end the list, not at the beginning where i could see all the recent pics

virgi26 ( 2017-03-07 21:54:49 +0200 )edit

I'm not sure if it related to whatsapp because I have the same behaviour. But with "Threema" also a android app, I have no problems at all. All pictures properly indexed and available in the app. My workaround is to send the picture with whatsapp and then share them with whatsapp (which works quiet good)

drummer12 ( 2017-03-08 08:38:23 +0200 )edit