Ask / Submit
13

[BUG][2.1.0.11] Can't update saved password in webbrowser

asked 2017-04-04 08:39:12 +0200

atlochowski gravatar image

updated 2017-05-03 19:59:10 +0200

It's impossible to update password saved password in webbrowser. It's always stays unchanged.

How to reproduce:

1. Open webbrowser
2. log to your account, for example your webmail   
3. save password in webbrowser
4. change your password
5.logout
6. log with new password
7. update password in browser
8. logout 
9. try to log in with saved password

UPDATE

when I launch Browser from terminal I receiving output like this

[W] unknown:25 - file:///usr/lib/qt5/qml/Sailfish/WebView/Popups/PasswordManagerDialog.qml:25: TypeError: Property 'sendAsyncMessage' of object QQuickItem(0x53d20ab0) is not a function

when I'm trying to Save or Cancel.

edit retag flag offensive close delete

Comments

Seems like I have a similar problem, but I can't seem to save any passwords at all. I don't know if it is since 2.1.0.11 or one of the earlier 2.1 versions, but it was definitly working with the pre-2.1 browser

seiichiro0185 ( 2017-04-04 09:03:42 +0200 )edit

@seiichiro0185 i've saved my password in some previous version so probably saving password doesn't work at all in this version.

atlochowski ( 2017-04-04 09:17:32 +0200 )edit

I found when on holiday (2.1.0.10) it wouldn't save the password for My3 mobile (which is irritating because I need it to monitor credit). I assumed it was my fault, that I'd accidentally declined to save (there were facebook overlays interfering). No way to change or reset the password/choice. (I even looked through all the files the browser uses - found passwords but no reference to My3.)

When I got home I cleared ALL passwords and tried it again, carefully. It still wouldn't save the password for My3 but it did save others.

So yes - a way of changing a saved password would be useful. And of listing sites that have passwords and clearing them individually (not displaying them) - I had no way of knowing whether I'd saved it or not.

Not tried 2.1.0.11 but seems unlikely this has changed.

DaveRo ( 2017-04-04 09:38:30 +0200 )edit

I tested this with Jolla1 Haapajoki 2.0.5.6 and the password was updated. So it looks like this bug has been introduced in 2.1.0.X update!

alloj ( 2017-04-04 10:45:57 +0200 )edit

1 Answer

Sort by » oldest newest most voted
2

answered 2017-05-15 15:05:49 +0200

rainemak gravatar image

This should be fixed in 2.1.1.x. Thanks for reporting.

Yeah, https://together.jolla.com/question/160284/usernamepassword-save-broken-in-browser-21011/ is a duplicate.

edit flag offensive delete publish link more
Login/Signup to Answer

Question tools

Follow
5 followers

Stats

Asked: 2017-04-04 08:39:12 +0200

Seen: 380 times

Last updated: May 15