Graphical glitch on lockscreen

asked 2017-04-29 14:07:28 +0300

Edz gravatar image

updated 2017-07-29 15:04:49 +0300

EDIT 29-07-17 - The glitch is no longer present in Jamsanjoki 2.1.1.24 on Jolla1 - fixed for all?, you tell me!

EDIT:- (some content removed) It looks like the problem is already present and has nothing to do with me adding modules or effects to the Clock.qml file.

UPDATE:- I found the cause of the flashing covers, but have little idea how to solve it, here's what I now know;

IF there are notifications of any type visible in Events view, then the glitch occurs, remove all notifications from events view, go back to lockscreen, unlock, change some ambiences a bunch of times and notice that there is no more 'flashing covers'

Steps to reproduce: (not 100% reproducible every time I've realised, YMMV)

  1. open a few apps and minimise them all.
  2. make sure you have at least one unread notification visible in events view.
  3. put the device in standby by either swipe down or tapping power button once.
  4. wake the device up to lockscreen.
  5. change to a few different ambiences......you should now be glimpsing 'flashing covers' as you change between ambiences.

To NOT see flashing covers; close any/all notifications in events view and start at step 3 as above.


My original comments;

I thought I'd read something similar here on TJC but failed to find it using search, it's possible I read it on TMO or even comments in Openrepos, I really can't be sure......so this post may be a duplicate of sorts, let me know.

The glitch only seems to occur when I change to another ambience while in lockscreen, I get a glimpse of any open covers in the multi-tasking area, they only flash up for a second. I tried to capture this with screenshot and failed, so i videoed it and then GIF'd it;

GIF

Possibly related: https://together.jolla.com/question/144154/bug-ui-first-icon-flashing-in-folders-with-many-items/

edit retag flag offensive close delete

Comments

1

The same here! So it definitely has nothing to do with your qml operations.

lakutalo ( 2017-04-29 19:33:20 +0300 )edit
1

Me too Jolla C 2.1.0.11

olli ( 2017-04-29 20:05:33 +0300 )edit

Thank you @olli - good to know it's not just Jolla1

Edz ( 2017-04-29 20:38:09 +0300 )edit
1

I was also able to reproduce the glitch On aquaFish

p_pahare ( 2017-04-30 12:50:18 +0300 )edit
1

I can absolutely confirm this and reproduce this. Also, I think it could be related to the flashing icon problem.

palikao ( 2017-05-01 16:26:57 +0300 )edit