Ask / Submit

[] android apps cannot show gallery' s photos even rebuild index by sailfish utilites tool [answered]

Tracked by Jolla (In progress)

asked 2017-04-30 01:28:54 +0300

juhhhk gravatar image

updated 2017-05-01 19:58:36 +0300

the native gallery is able to show all photos, however, some photos are missing even rebuild media index with native utilites tool when i tried to send photos to my friends with Whatsapp or LINE apps.

please help T_T...

updated: i could see the photos when shared photos with whatsapp/LINE but it is not work after OS updated to 2.1.

edit retag flag offensive reopen delete

The question has been closed for the following reason "the question is answered, an answer was accepted" by juhhhk
close date 2017-08-30 18:30:10.627099



install Solid Explorer and use it for sharing your photos from android apps.

coderus ( 2017-04-30 12:49:10 +0300 )edit

thank you @coderus, good temp fix :p

juhhhk ( 2017-04-30 13:35:57 +0300 )edit

i do not think that you can call this a bug. it is just a non-implemented feature. (regarding your tagging)

pawel ( 2017-05-01 07:52:39 +0300 )edit

I have also a Problem with the Galery, maybe its for the same reason. not all the Pictures i see in Galery Folder are shown in the Galery. it was different before the last Update.

Raymaen ( 2017-05-09 18:37:20 +0300 )edit

4 Answers

Sort by » oldest newest most voted

answered 2017-05-04 09:21:03 +0300

Sage gravatar image

There is one fix that is coming with 2.1.1 or newer release that will help onthis matter. Unfortunately I can't promise when this will be available. Stay tuned. Set tracking for this issue.

edit flag offensive delete publish link more


User will like it and thank you so much :)

juhhhk ( 2017-05-05 13:43:15 +0300 )edit

Not fixed for Jolla 1

hoschi ( 2017-08-03 22:15:37 +0300 )edit

answered 2017-05-02 17:46:41 +0300

DrYak gravatar image

An alternative solution :

  • (Instead of using an app to force the update of the database, so latest photos show on WhatsApp's send photo picker)

  • Try downloading some file explorer app (e.g.: ES File explorer - direct download without store )

  • Then navigate to where your JPEG file is located ( e.g.: /media/sdcard/{uuid}/Pictures/Camera/ if you store them on SD Card)
  • Long press the JPEG file (to select it)
  • Use the share button
  • Then pick-up the app you want to share with (e.g.: WhatsApp)

This bypasses the database and directly let you select the JPEG file you want to share.

That's waht I do when I don't have the patience to wait for the DB to update.

edit flag offensive delete publish link more

answered 2017-05-09 16:51:38 +0300

DarkTuring gravatar image

updated 2017-05-09 18:09:27 +0300

To make Amdroid see the files you have to change permissions amd allow group Others read/write access.

Try on one image or recursively allow access in terminal after enabling developer mode.

chmod -R a+rw /home/photos

Also see link

Something like that and Android now will be able to read the images.

In addition, sudo-dev password and bind the sdcard to nemo folder sdcard you create, or android_storage sdcard folder:

--bind /home/media/sdcard/##-##--### /home/nemo/sdcard OR /home/nemo/android_storage/sdcard

edit flag offensive delete publish link more

answered 2017-05-01 07:56:38 +0300

pawel gravatar image

it this is a duplicate:

of this:

then yours would be a duplicate too.

but i do not understand why the first question was closed.

edit flag offensive delete publish link more


The question was closed since they fixed in os update. But it happened again and it is not expected i think.

juhhhk ( 2017-05-01 20:04:17 +0300 )edit

@pawel you marked your comment amd links as an answer but both links provide absolutely no solution to the permission problem.

DarkTuring ( 2017-05-09 16:45:00 +0300 )edit

Question tools



Asked: 2017-04-30 01:28:54 +0300

Seen: 734 times

Last updated: May 09 '17