add complete rcu protection around np->opt in kernel-ipv6 CVE-2016-3841 critical

Tracked by Jolla (In progress)

asked 2017-05-09 12:54:38 +0300

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

updated 2017-05-09 12:54:38 +0300

lpr gravatar image

Description
The IPv6 stack in the Linux kernel before 4.3.3 mishandles options data, which allows local users to gain privileges or cause a denial of service (use-after-free and system crash) via a crafted sendmsg system call. CVSSv3: 7.3 high (attack range: local)

An upstream-fix is available and should be backported (maybe look at debian-wheezy-kernel3.2.78-1)...

Files affected: kernel-adaptation-sbj-3.4.108.20161101.1/ various

edit retag flag offensive close delete