Ask / Submit
0

Harbour detects app version as 2.1.0.*, but it works on 2.0.5

asked 2017-05-25 09:26:50 +0300

amica gravatar image

updated 2017-05-25 09:30:01 +0300

From the “OS version limits” drop-down at harbour.jolla.com, I can only select “---” or “2.1.0.*” when submitting an app, but I would like to select 2.0.5 so I can see an own app in Jolla store and install it from there instead of deploying the RPM through SailfishOS SDK. I'm running 2.0.5.6 (Haapajoki) (armv7hl) on my device.

If that OS version detector is right and the app is really only compatible from e. g. 2.0.5.4 but would fail on all devices between 2.0.5.0 and 2.0.5.3, how can I know which features caused the incompatibility, so that I could refactor them for broader backwards compatibility?

Best regards

Amica

edit retag flag offensive close delete

2 Answers

Sort by » oldest newest most voted
2

answered 2017-05-25 16:46:17 +0300

leszek gravatar image

If you compile your App with the new SDK against Qt5.6 it won't work with earlier SailfishOS versions featuring Qt5.4(2)

edit flag offensive delete publish link more
1

answered 2017-05-25 13:42:46 +0300

It's all about the modules you use... For example: nemo configuration module makes it easy to store the user configuration for an app and is available for ages on Sailfish OS. But it's allowed in Harbour since 2.1.0.X.

My apps uses this module and they work on <2.1.0.X too but it's Harbour compatible only from 2.1.0.X and higher.

edit flag offensive delete publish link more

Comments

I used only

import QtQuick 2.0 import Sailfish.Silica 1.0

amica ( 2017-05-25 16:03:54 +0300 )edit

As @leszek answered here too, the SDK version plays also a roll. The modules from the newest SDK use QT 5.6 which is only allowed in 2.1.0.X

Dylan Van Assche ( 2017-05-25 17:12:01 +0300 )edit
Login/Signup to Answer

Question tools

Follow
1 follower

Stats

Asked: 2017-05-25 09:26:50 +0300

Seen: 180 times

Last updated: May 25 '17