We have moved to a new Sailfish OS Forum. Please start new discussions there.

Alarm clock indicator is missing when using community translations [released]

asked 2017-06-08 11:00:49 +0300

werdinand gravatar image

updated 2017-10-03 01:11:42 +0300

nthn gravatar image

The alarm clock indicator in the status bar is missing and doesn't come back with restart or turning alarm off and on.

Update by martonmiklos 2017-10-02: It turned out that the community localizations had not ran the localedef command properly. It is going to be fixed with the next releases of the community translation packs. Dutch, Chinese (Taiwan), Estonian, Hungarian is updated.

edit retag flag offensive reopen delete

The question has been closed for the following reason "released in a software update" by werdinand
close date 2017-10-03 00:51:53.200171

3 Answers

Sort by » oldest newest most voted

answered 2017-06-08 11:42:06 +0300

Naecken gravatar image

You are using unofficial translation packge.

In terminal enter this code:

localedef -i et_EE -f UTF-8 et_EE.utf8

And restart device.

edit flag offensive delete publish link more


Still missing...

werdinand ( 2017-06-08 11:47:59 +0300 )edit

The rpm spec file runs the following command:

localedef --replace -i %{LOCNAME} -f UTF-8 %{LOCNAME}.utf8 --prefix=/

What I can see in this case: I have messed up, used et_ET LOCNAME instead of et_EE.

martonmiklos ( 2017-06-08 13:11:27 +0300 )edit

I tried the command with --replace and --prefix=/ but still no alarm indicator.

werdinand ( 2017-06-08 17:15:06 +0300 )edit

I have seen the similar behaviour with the mute icon. Could you please check that if you mute your device (with volume down) will the mute indicator appear? The Alarm clock symbol does not appear to me either (Hungarian locale).

martonmiklos ( 2017-06-08 17:31:28 +0300 )edit

Mute icon works fine.

werdinand ( 2017-06-08 17:43:57 +0300 )edit

answered 2017-09-30 13:20:28 +0300

nthn gravatar image

Set your language to one of the officially supported languages (Finnish, English, ...), then set it back to Estonian. This should fix the problem.

edit flag offensive delete publish link more


Nope, doesn't work. In English there is the indicator but in Estonian still nothing.

werdinand ( 2017-09-30 21:59:56 +0300 )edit

Strange, that seemed to be what fixed it for me. Although come to think of it, maybe the way to solve it is by first uninstalling and reinstalling the community translation packages, and then switching to an official language and back. I went like this: uninstall and reinstall Dutch and Hungarian translation packages, then from Dutch (problem) to Hungarian (can't remember if it showed the indicator at that point or not) to Finnish (no problem) and finally back to Dutch (no problem). I hope you'll be able to fix it through a similar procedure.

nthn ( 2017-10-01 02:05:37 +0300 )edit

Well, my phone died at some point a couple of hours ago, and now the problem is back. I've tried switching back and forth between several languages, and nothing works. Absolutely no idea what the real solution actually was.

nthn ( 2017-10-01 20:07:14 +0300 )edit

I noticed 'locale -a' doesn't actually show any of the community translations as being available. Maybe this is where the issue is located. @martonmiklos@sledges?

nthn ( 2017-10-01 21:24:42 +0300 )edit

@nthn I wanted to write you on Github, but I got interrupted by different stuff.

Here is what I see now: - I have a Jolla C which had been factory resetted recently, and the Hungarian translation was installed from the Openrepos. It did not listed the hu_HU.utf8 in the locale -a output just as your device. - The RPM script runs the localedef without the --force argument. - Once the localedef was run on my device by hand with the --force argument the hu_HU.utf8 appeared in the list and afterward when installed other community language packs their locale just installed fine.

As a fix I have changed the localedef command in the RPM postinstall script to use the --force option. I have just updated the Dutch translation on Openrepos, if you have a "community translation virgin" device at hand please testdrive and report back. Thanks!

martonmiklos ( 2017-10-02 22:00:45 +0300 )edit

answered 2017-10-02 23:14:44 +0300

nthn gravatar image

The problem is fixed with the latest update of the Estonian translation pack available on OpenRepos. Just install and restart your device, and the alarm icon will be there (if you have alarms set). All other locale-related issues should also be fixed.

edit flag offensive delete publish link more


Still nothing. Updated and restarted but no indicator. Should it work just with update or should I first remove language pack and then reinstall it?

werdinand ( 2017-10-02 23:42:38 +0300 )edit

Maybe you have to remove and then reinstall it. I did so accidentally, but it might be the way to trigger all the right scripts.

nthn ( 2017-10-02 23:49:46 +0300 )edit

To be completely sure, try 'locale' in a terminal. If it doesn't give any error messages, the alarm icon should be displayed.

nthn ( 2017-10-02 23:50:58 +0300 )edit

Looks like the packages received another update (-0.0.2), make sure you install those.

nthn ( 2017-10-02 23:54:46 +0300 )edit

Updated to -0.0.2 (with several restarts and so on) - still no indicator. Locale says: Locale: Cannot set LC_CTYPE to default locale: No such file or directory Locale: Cannot set LC_MESSAGES to default locale: No such file or directory Locale: Cannot set LC_ALL to default locale: No such file or directory

werdinand ( 2017-10-03 00:18:21 +0300 )edit

Question tools

1 follower


Asked: 2017-06-08 11:00:49 +0300

Seen: 322 times

Last updated: Oct 03 '17