Ask / Submit
21

Here WeGo positioning

asked 2017-06-08 16:41:14 +0300

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

updated 2017-06-08 16:41:14 +0300

Mr.Heat gravatar image

Any information on the sudden non-functioning of Here WeGo location? Last weekend noticed that my Jolla-C Here WeGo couldn't find location eventhough GPS worked and by downloading modRana was able to locate my position. Any information on this as the Jolla Store has had multiple comments already that positioning in Here WeGo doesn't work?

edit retag flag offensive close delete

Comments

1

What version of Sailfish are you using? What version of Here WeGo are you using? What 'locate' options do you have set? What happens if you delete and re-installed Here WeGo?

Why is this a wiki?!

timearp ( 2017-06-08 16:50:43 +0300 )edit

On Jollafied AquaFish running latest version of Here WeGo 2.0.11510 - 8.30.70.153 no such problems.

aspergerguy ( 2017-06-08 17:05:22 +0300 )edit
2

I had the same problem with 1:2.0.11430 on Jolla C and downgrading helped. Tried 1:2.0.11510 from jolla store, but doesn't work for me. See also store comments, there are others that report the same problem. Best way is to give feedback from the app (feedback => get support) to get your problem in the ticket system of here

rgrnetalk ( 2017-06-08 18:45:07 +0300 )edit

After install version com.here.app.maps-2.0.11424 the app job normal with your GPS. Who have problems please downgrade version!

Rafaelvlmendes ( 2017-06-08 20:42:55 +0300 )edit

I confirm downgrading works, I'm using 2.0.11397 but some newer version could work.

walrus ( 2017-06-08 21:55:48 +0300 )edit

3 Answers

Sort by » oldest newest most voted
2

answered 2017-06-22 20:41:57 +0300

Hilleberg gravatar image

I solved the problem. I installed an older version of here (2.0.11424) and it works. Thanks

edit flag offensive delete publish link more

Comments

That's a workaround :) It's truely fixed when Here Technologies release a workin version - which according to @rgrnetalk is in the works.

Direc ( 2017-06-23 13:50:08 +0300 )edit
0

answered 2017-06-18 15:23:19 +0300

accumulator gravatar image

updated 2017-06-23 09:25:25 +0300

Not a real solution, but what did work for me (Intex AF) was installing an older version from https://www.apk4fun.com/history/30429/ I went with the one from Feb 22 and that works as expected. I'd rather install from Store though :/

NOTE: As @DarkStarSword below writes, you'll lose your downloaded maps, because you first have to uninstall Here WeGo before you can install the one from apk4fun!

edit flag offensive delete publish link more

Comments

I'd also rather install from the store - uninstalling HERE to install an older version meant that all the maps I had downloaded for offline use were wiped out and I had to download them again.

DarkStarSword ( 2017-06-22 16:48:12 +0300 )edit
-1

answered 2017-06-22 15:05:25 +0300

Direc gravatar image

Workaround: Install GPSInfo from Jolla store, start it and wait until you have a GPS fix, leave it on and then start HERE WeGo, or Sports Tracker, or any other Android app not getting pisition otherwise. Location should now be immediately available.

Perhaps Jolla could have a look at this bug?

Oh yeah. Tested on Jolla 1.

edit flag offensive delete publish link more

Comments

It's not a Jolla issue, but a Here WeGo issue.

ziellos ( 2017-06-22 16:26:27 +0300 )edit

I'm not sure you are seeing the same issue - activating the GPS via other means did nothing to help HERE WeGo track location after the initial fix (I used the GPS test in the built in CSD tool accessed via rapidly tapping the build number in settings->about product 5 times, but I don't see any reason that would be any different to using GPSInfo), and other Android apps (and older versions of HERE) are not affected. I'm using an Aqua Fish - from what I gather this issue is also present on Jolla C, but I haven't seen this mentioned on Jolla 1.

DarkStarSword ( 2017-06-22 16:39:15 +0300 )edit

I may have encountered a different issue, then. If I have GPS enabled and no app reading the location, WeGo can't make the GPS icon appear. If, say, GPSInfo already uses GPS i.e. the icon is there already, WeGo can use the location just fine. That was what I tried to explain.

Direc ( 2017-06-22 18:53:52 +0300 )edit

I'm using 2.0.10965, newest from Aptoide, hence I don't suffer from that bug.

Direc ( 2017-06-22 19:59:02 +0300 )edit
Login/Signup to Answer

Question tools

Follow
6 followers

Stats

Asked: 2017-06-08 16:41:14 +0300

Seen: 1,088 times

Last updated: 2 days ago