Office 365 exchange sync stops when changing the network

Tracked by Jolla

asked 2017-07-05 21:49:34 +0300

Caluna gravatar image

updated 2017-07-05 22:24:49 +0300

Hi, Using an Office365 account, synchronisation of E-mails works nicely after reboot (Jolla C; Sailfish OS 2.1.0.11) for some time. Then it "suddenly" stops and only a reboot helps to re-initiate synchronisation. I think, the problem is related to switching between networks: When I leave the connection area of my W-lan, the phone seems to be without any connection for some seconds. This seems to break the ability for synchronisation. Only reboot helps. Same happens if I am on cellular network and enter a new W-Lan connection (e. g.: when I come home). Is there any idea or work around? It is annoying to always reboot the device when chaning he network. Best C. Edit:

Here is an extract from the log file:

eas.log

edit retag flag offensive close delete

Comments

I couldn't obverse such a behaviour with my office 365-account. Maybe you can enable debugging (and find a hint why it is broken?

https://together.jolla.com/question/145289/exchange-account-logging-for-connectivity-errors/

caesium ( 2017-07-05 21:59:22 +0300 )edit

I can second this observation, I think. I see the exchange account stuck in "Updating account...".

sidv ( 2017-07-07 00:20:36 +0300 )edit

Correct - any ideai or work around?

Caluna ( 2017-07-07 09:33:34 +0300 )edit

Nothing besides the reboot you already mentioned. Very rarely it seems to "autofix" if I move between networks. I should add in my case it is a company exchange server (not that it really matters).

sidv ( 2017-07-08 06:13:23 +0300 )edit

Still an issue with 2.1.1.23.

sidv ( 2017-07-24 21:07:46 +0300 )edit