Ask / Submit
0

Fastboot on Jolla 1

asked 2017-07-16 12:23:20 +0300

PureTryOut gravatar image

I'm trying to access my phone in fastboot mode (the reason why does not really matter). The phone boots into fastboot mode fine, but it doesn't appear in the list when running "fastboot devices". I've tried unlocking the bootloader via recovery mode (which I could access fine via telnet), but nothing really changed.

I'm normally running Gentoo Linux on my pc, but installing fastboot in an Ubuntu LiveCD didn't help either so it doesn't seem to be a missing driver. What exactly am I doing wrong?

edit retag flag offensive close delete

Comments

try with sudo ;)

coderus ( 2017-07-16 16:43:08 +0300 )edit

Did so, no luck

PureTryOut ( 2017-07-16 17:03:10 +0300 )edit

Well so far I figured out my PC does see it; if I "cat" "/var/log/syslog" it does show up, but it does not know what to do with it. I had this same problem with a MTP device before, and the solution then was to add an udev rule. However I'm not sure what udev rule I would need in this case.

PureTryOut ( 2017-07-28 16:07:12 +0300 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2018-03-17 16:33:02 +0300

Amboss gravatar image

updated 2018-03-17 16:33:32 +0300

Late, but if anyone checks this, there will be at least an answer. As I have recently found out with the help of #jollamobile you need to specify vendor:

fastboot -i 0x2931 devices

I tested this for Jolla 1. You will need to specify this option on a command you send with fastboot

edit flag offensive delete publish link more
Login/Signup to Answer

Question tools

Follow
1 follower

Stats

Asked: 2017-07-16 12:23:20 +0300

Seen: 479 times

Last updated: Mar 17