Ask / Submit

General Yahoo email account authentication problem

asked 2017-07-22 08:16:08 +0200

lfc22 gravatar image

updated 2017-07-24 10:55:58 +0200

jovirkku gravatar image

Started seeing issues w/ yahoo email account a few days ago, it no longer updates. Tried deleting and creating a new general email account for the same id, and now seeing authentication error "Problem with authentication", so even account cannot be created. Also tried setting up another general email account for a gmail id, same authentication problem.

Is anyone else having email update/authentication issues? (onyx w/ ported Iijoki)

edit retag flag offensive close delete



I have the same problem with yahoo email account, the same SFOS version, but on JollaC.

MariusP ( 2017-07-22 09:15:14 +0200 )edit

Same problem here. Am on Yahoo. Lijoki. Aquafish made into Jolla c. Everything was working wonderfully up to 48 hours ago, now i get the 'problem signing in message'. I have noticed the password lenght in server settings is 7 characters, which is shorter than my one. I have tried to change it with the right one to no effect, but whenever i go back to settings I still see a 7 characters password...

enrish ( 2017-07-23 13:19:51 +0200 )edit

Yep same issue came up with my Yahoo email account as well

Mariusmssj ( 2017-07-23 16:11:43 +0200 )edit

i had.the.issue.on jolla1, but last week when i did setup aquafish phone for my wife, it did work and still does. e-mail yahoo i mean

pawel ( 2017-07-24 10:26:32 +0200 )edit

I'm facing the same issue. Was working a couple of weeks back.

utkarsh ( 2017-07-24 19:56:15 +0200 )edit

8 Answers

Sort by » oldest newest most voted

answered 2017-07-29 00:13:17 +0200

lfc22 gravatar image

updated 2017-07-29 00:22:00 +0200

I verified that the authentication problem can be resolved by using another authentication method that currently does not exist when creating a General Email account for Yahoo with existing SFOS UI.

The details of the authentication change are mentioned in this Yahoo forum:

The gist is that the IMAP authentication method has changed to "login" from "plain". This thread on TMO discusses usage of ag-tool to root cause and temporarily patch the behavior:

If you try to create an account today using existing interface and push accept, authentication fails. If you do not revert to Manual or close the "Accounts" UI, the account is still there, so you can use ag-tool in terminal to dump out the settings and see it was created with authentication method "2" for imap which is "Plain".

// To list existing accounts, and indicate account ID:

ag-tool list-accounts

// To list all the settings:

ag-tool list-settings accountID

You can then follow up with another ag-tool cmd to change that setting to "1" which is "Login".

// To change authentication method, account ID in this case was 84

ag-tool update-service 84 email int:imap4/authentication=1

If you then open Email, you'll see the yahoo account email starting to update. The problem is, this change is not sticky. It is only viable as long as you keep the rejected Accounts UI "alive" i.e. do not close or change it in any way.

There may be a method to make it sticky but I have not figured it out yet. The person most knowledgeable in this area appears to be VDVsx ( though I'm not sure he is still active here.

Alternatively Jolla can implement an authetication menu choice on the General Email account UI to allow folks to select which method to use (none, login, plain, CRAM-MD5) for IMAP. There is already an ON/OFF authentication option today for SMTP.

Does anyone have any other ideas?

edit flag offensive delete publish link more


thanks for investigating this. Almost there, hope someone else pinches in.

enrish ( 2017-07-29 01:48:49 +0200 )edit

Genuis, works like a charm. Thanks for figuring it out yourself. My yahoo mail updates once again after so long, as I didn't delete my yahoomail account from my Jolla 1 while this was going on, so just followed your instructions to change the authentication method and it worked. Thanks once more.

DameCENO ( 2017-08-02 17:42:39 +0200 )edit

This does not work for me. I still cannot send or receive emails (authentication error), there is not even an "Inbox" folder for the account.

William ( 2017-08-07 14:43:30 +0200 )edit

Today I tried again and it worked. It is important to update the email account from email app before actually tapping the account or restarting the phone. Otherwise one will get into the "Draft" folder, and the "Inbox" folder never synchronizes.

William ( 2017-08-08 12:30:03 +0200 )edit

No matter what I try, I cannot get it to give me anything but the Draft folder. Other than the great guide and tips here, is there any other way to get around this problem?

hoppysfave ( 2017-08-12 06:55:21 +0200 )edit

answered 2017-07-31 19:19:27 +0200

enrish gravatar image

updated 2017-07-31 19:20:54 +0200

Finally found a way to make it work. Kudos to lfc22 for his findings. Follow the procedure he describes in his answer until the end. As he says, be careful never to close or change the rejected Accounts UI, simply keep it there as a cover. After you opened the email app and updated, side swipe home, pull down the ambiance menu, press the on/off hard key on the right and press the reboot button that appeared in the top menu (you must have enabled it in settings / developers tool). When the phone restarts, the working account is still there. Hooray. Probably it works by rebooting in any other way, but now I feel too lucky to mess up with it again.

edit flag offensive delete publish link more


Now why didn't I think of that ;-) awesome finding enrish! Tried it and it works. Would still be nice if jolla implemented the enhancements requested, but I can live with the workaround.

lfc22 ( 2017-08-01 06:15:13 +0200 )edit

@lfc22 Probably because such a solution was too ugly :) Glad I could help back somehow. The implementation from Jolla is definetely needed, even more because this is not only a Yahoo mail issue but involves any account requiring a different login method (your original title was more appropriate).

enrish ( 2017-08-01 12:13:08 +0200 )edit

Works for me on Jolla 1 as described by @lfc22 and @enrish, great! Thanks!

canne ( 2017-08-03 19:20:45 +0200 )edit

answered 2017-07-23 13:50:12 +0200

dingo gravatar image

Hi, I have the same problem here...any solution?

edit flag offensive delete publish link more


I guess yahoo might have changed something with their authentication that SailfishOS does not support, thus we can no longer log in :(

Mariusmssj ( 2017-07-23 16:13:04 +0200 )edit

@dingo convert your answer to a question which this is. The answer option is meant only for contributing a way or the other to the asked question, it is not meant to be used to repeat the question already on the table

DameCENO ( 2017-07-24 18:46:27 +0200 )edit

answered 2017-07-24 18:57:02 +0200

DameCENO gravatar image

I did experience this same issue on my jolla 1 a while back it was due to yahoo's strict policy of updating user details, so I had to update my details which involved changing my 10 years old password with something quite robust, after that the option of enabling third party apps from assessing your account was showed, had to keep it enabled. After that my yahoo account on jolla was re-added successfully. Hope this helps

edit flag offensive delete publish link more


Thanks for the response. I already had 3rd party app enabled for a long time. I did change password and tried again, tho that didn't help.

BTW, my N9 has no issues, even after changing password etc. As I mentioned before, this is a recent change, things worked fine for a long time (ever since Saimaa). I'm wondering if this is related to Verizon taking over yahoo email recently.

Incidentally,I did try setting up a new gmail account, that also did not work. However I have no knowledge whether it ever did.

lfc22 ( 2017-07-24 19:05:06 +0200 )edit

I have issues in my Jolla and in my PC (Thunderbird). I think that something has changed in YahooMail, so it's not only a Jolla issue

carmenfdezb ( 2017-07-24 22:30:57 +0200 )edit

For me it is a Jolla issue. In Thunderbird it is working! @carmenfdezb

donni106 ( 2017-08-12 17:43:26 +0200 )edit

answered 2017-07-25 18:29:45 +0200

enrish gravatar image

updated 2017-07-26 03:33:37 +0200

Ok, this is a partial workaround. I erased my mail (yahoo) account on my phone and recreated it choosing the POP settings as described here: link text Now it works for sending and receiving emails (the major downside is that with a new account the phone keeps downloading mails from years and years ago, with loads of annoying notifications... have to find a way to stop it, but this is yet another issue).

edit flag offensive delete publish link more


Same here, only works with POP.

IMAP has authentication issues with yahoo mail. Pretty annoying.

William ( 2017-07-26 09:08:45 +0200 )edit

answered 2017-07-26 17:03:56 +0200

wpeberg gravatar image

It is a problem of yahoo IMAP server. Yahoo supposedly fixed it, but still are issues of imap not working. you have to change IMAP from to

Strangly works again on desktops mail clients but not on the phone. But also I am using Claws-mail in two different netbooks, on one the "" works and on the other one just "". ?

edit flag offensive delete publish link more


Thanks wpeberg, did not work here :( Maybe you know how to change the authentication method to AuthMechs LOGIN (see my comment above)?

enrish ( 2017-07-26 18:53:00 +0200 )edit

answered 2017-09-21 19:28:27 +0200

carmenfdezb gravatar image

updated 2017-09-21 19:29:54 +0200

Sorry, I had completely forgotten this seems that Yahoo fixed it so Yahoo Mail is already working on my Jolla @lfc22, or others users, can you confirm that it's working for you?

edit flag offensive delete publish link more


it works again for me since updated to . I can't tell if due to the upgrade or if Yahoo changed something.

rtr2001 ( 2017-09-21 21:11:21 +0200 )edit

I've been using the workaround outlined above, I have not deleted the account and tried to set it w/o the workaround. However, as I stated previously in this thread, I still think that Jolla should implement more flexibility into user choices for authentication in the General email account UI: "Alternatively Jolla can implement an authentication menu choice on the General Email account UI to allow folks to select which method to use (none, login, plain, CRAM-MD5) for IMAP. There is already an ON/OFF authentication option today for SMTP.".

After all, tomorrow, Yahoo may decide to change their minds again, or some other random email provider for which we use the General email UI to set things up. What then?

lfc22 ( 2017-09-21 21:13:19 +0200 )edit

answered 2018-03-12 13:30:23 +0200

So sorry to hear that you are getting such problems regarding your Yahoo email. Yahoo can misbehave sometimes because of connection overriding. But don't worry we can always help you regarding any problem your Yahoo email account. Contact Yahoo customer support to resolve these issues and you won't have to suffer any longer.

edit flag offensive delete publish link more
Login/Signup to Answer

Question tools



Asked: 2017-07-22 08:16:08 +0200

Seen: 960 times

Last updated: Mar 12