WLAN and BT loosing connection together, headset with WLAN on is unusable

asked 2017-08-01 04:05:41 +0200

JP1 EA 2.1.1.23, 2.1.1.24

This wasn't so bad before. I can't use the BT head set while APs are around and WLAN is on.
Very often, but not always, the head set gets disconnected when the AP changes. Sometimes it is as easy as switching off the connected saved network and get a BT disconnect.
Switching WLAN off and on sometimes brings the head set back.

When things turn really bad, reboot is the only thing that helps. Inbetween, there are a lot of pattern, I can't figure...

  • "Wifi Analyzer" starts "loosing" BSSIDs.
  • "Wifi Analyzer" screen update stops.
  • No matter what I do, my head set doesn't reconnect.
  • Pairing fails.

In the log one can find such things:
Jul 27 21:53:06 amJolla kernel: wlan: [3484:E :PE ] limHandleHeartBeatFailureTimeout: 7398: Probe_hb_failure: SME 12, MLME 16, HB-Count 0
Jul 27 21:53:06 amJolla kernel: wlan: [3484:E :PE ] limHandleHeartBeatFailureTimeout: 7404: Probe_hb_failure: for session:0
Jul 27 21:53:06 amJolla kernel: wlan: [3484:E :SME] csrNeighborRoamIndicateDisconnect: 3033: Disconnect indication on session 0 in state 2 (sub-state 0)
Jul 27 21:53:06 amJolla kernel: wlan: [3484:E :TL ] ----> CRegion 0, hRSSI -33, Alpha 5
Jul 27 21:53:06 amJolla kernel: wlan: disconnected
Jul 27 21:53:06 amJolla wpa_supplicant[3500]: wlan0: CTRL-EVENT-DISCONNECTED bssid=18:a6:f7:2f:31:98 reason=8

Aug 01 00:05:14 amJolla dbus[802]: [system] Rejected send message, 4 matched rules; type="method_return", sender=":1.30" (uid=100000 pid=1347 comm="/usr/bin/pulseaudio --start -n --file=/etc/pulse/a") interface="(unset)" member="(unset)" error name="(unset)" requested_reply="0" destination=":1.19" (uid=0 pid=1087 comm="/usr/sbin/bluetoothd -n ")
....
Aug 01 00:05:17 amJolla kernel: wlan: [824:E :SME] csrNeighborRoamHandleEmptyScanResult: 1363: Registering DOWN event neighbor lookup callback with TL for RSSI = -79

BTW, I noticed it as I was walking along a corredor with 3 APs with distinct SSIDs, and my head set got disconnects and reconnects.
While in this case the dropping of the signal strenght was the trigger, in the tests at home, the phone was about 1 m from 2 APs (3 SSIDs).
Switching BT off renders pings stats with no packet loss for 30 min. at the same place.

edit retag flag offensive close delete