Ask / Submit
1

[Aqua Fish / Jolla C] Developer Mode missing after 2.1.1 update [answered]

asked 2017-08-07 11:08:16 +0300

ghling gravatar image

updated 2017-08-07 12:17:53 +0300

I just realized that the "developer mode" option is missing in the Settings on my Jolla C-converted Aqua Fish after the 2.1.1 Updates. It was present before (in "Settings" - "System" as last entry below "Certificates" if I remember correctly), but now it is gone and I can't enable the mode.

For testing purposes I have removed all patches via Patchmanager, rebooted the device multiple times, but to no avail. Unfortunately, without Developer Mode I can't get a console / SSH connection to further analyze the problem. My best bet would be an incomplete update / package conflicts (even though the updates all went well according to the updater).

Does someone have any ideas how I might get it back without having to factory reset the phone or how to analyze the issue further?

SOLVED: To summarize the solution: The package jolla-settings-system-developermode was missing on my system. I installed fingerterm from harbour via Warehouse and then used it to install the missing package:

pkcon refresh
pkcon install jolla-settings-system-developermode
edit retag flag offensive reopen delete

The question has been closed for the following reason "the question is answered, an answer was accepted" by ghling
close date 2017-08-07 12:16:37.806779

Comments

What if I cannot install 3rd party packages? How do I enable installing untrusted software? I guess I'm missing that option as well

Vadim ( 2017-10-11 12:37:45 +0300 )edit

I would like to know how to use pkcon without Developer mode. I do have Fingerterm already installed, but I'm missing devel-su. I don't have root password either to use devel-su or su. Is there another way to set the root password than through Developer mode?

Juha88 ( 2018-01-04 09:35:58 +0300 )edit

1 Answer

Sort by » oldest newest most voted
2

answered 2017-08-07 11:13:44 +0300

r0kk3rz gravatar image

Can you install third-party packages? because you should be able to install fingerterm by itself.

There was a change in patterns with this latest update, and so you may need to install package jolla-developer-mode

edit flag offensive delete publish link more

Comments

Great idea, thanks. I have installed fingerterm via Warehouse and can run it. Trying to install the jolla-developer-mode via pkcon shows the issue/error:

Fatal error: jolla-developer-mode-0.3.26-10.27.4.jolla.armv7hl requires openssh-server, but this requirement cannot be provided

It seems somehow the package cache was outdated. After updating it, i was able to install jolla-developer-mode and now it is present again:

pkcon refresh
pkcon install openssh-server
pkcon install jolla-developer-mode

The pkcon install for jolla-developer-mode wants to install all kind of additional packages and crashed during the first run ("The daemon crashed mid-transaction!"), but the second attempt went fine. Fortunately this could all be done as user since devel-su is installed / enabled via the developer mode.

Anyhow, thank you very much for your fast answer. It works again.

ghling ( 2017-08-07 11:32:15 +0300 )edit

Ok, while I could install the developer-mode again via the terminal, it did not seem to have solved the actual problem. Once I disable the developer-mode via the settings, the entry disappears again. So the only option to currently enable it is to reinstall the jolla-developer-mode package via the terminal. This works, but is not that convenient.

ghling ( 2017-08-07 11:38:40 +0300 )edit

disabling it must remove that package, maybe just turn off the remote connections instead?

maybe try just installing jolla-settings-system-developermode instead of pulling it in as a dependency

r0kk3rz ( 2017-08-07 12:01:23 +0300 )edit

From experience I'd also expect that the jolla-developer-mode package gets removed when disabling the Developer Mode (and gets installed when you enable it). However, this should not remove the entry under Settings, so you can enable it via the GUI at a later time.

Personally, I can live with either only disabling the Remote connections or installing the package via the terminal. However, if other people experience the same issue we should further look into it.

ghling ( 2017-08-07 12:09:45 +0300 )edit

Bingo, the jolla-settings-system-developermode package was missing. After installing it via pkcon, the entry stays even if the jolla-developer-mode package gets removed. I have no idea how this package went missing during the update (probably due to broken dependencies resulting from an outdated cache, as seen above when trying to first install the jolla-developer-mode package). But the problem really seems to be solved now.

Thank you again for your great support!

ghling ( 2017-08-07 12:14:07 +0300 )edit

Question tools

Follow
1 follower

Stats

Asked: 2017-08-07 11:08:16 +0300

Seen: 380 times

Last updated: Aug 07 '17