mobile data transfer stalls a couple of minutes after connection

asked 2017-08-15 18:47:23 +0300

Self-Perfection gravatar image

updated 2017-08-17 15:28:12 +0300

jiit gravatar image

I observe following bug on my Jolla C for about 3 months. In subway mobile data transfer works for couple of minutes and then stops working. Connection icon is still shown but packages do not pass through. The device becomes effectively offline, though SailfishOS supposes it is still online. It is enough to trigger airplane mode on/off or restart network connections and after the device reconnects to mobile network data transfer works for another couple of minutes. But in places other than subway carriages mobile data works reliably.

Finally I became frustrated with requirement to trigger airplane mode manually every several minutes and wrote stupid script, that tries to ping and triggers airplane mode if there is no response. Though it is not a solution but a duct tape workaround.

I've asked recently at https://t.me/sailfishos and discovered a couple of more users noticed similar issue. They use different mobile network operators, BTW.

edit retag flag offensive close delete

Comments

2

Would you please do the following to collect some logs about this peculiar issue:

  1. Install oFono Logger from Jolla Store.
  2. Launch the app.
  3. Swipe left to get to the options.
  4. Pull down to enable all categories to log. Swipe right.
  5. Run your test case in the subway (i.e. try to reproduce the issue).
  6. Return to oFono Log app. You can see the log on the display. Scroll to the top of it.
  7. Pull down "Pack and Send" and select how to send. With email your log goes easily to the predefined address (=Jolla R&D, telephony engineer).
  8. Instead of #7, pull down and use "Save to Documents": the log file is saved to /home/nemo/Documents. Attach the tarball here.
  9. Swipe right and then left to get to the category list. Pull down to disable all.
  10. Close the app. Consider removing it, too.
jovirkku ( 2017-08-16 12:10:33 +0300 )edit