Sailfish keeps on forgetting Wifi passwords [duplicate]

asked 2017-09-19 10:24:23 +0200

skadge gravatar image

Since two-three months (ie, one or two sailfish updates -- I'm currently running 2.1.1.26), my Jolla phone randomly forget Wifi passwords of known Wifi network.

Sometimes after a couple of day, when I try to reconnect to a known network, the phone asks again for my credentials, sometimes when reconnecting even after a couple of minutes.

This does not prevent me to use the phone, but it is certainly irritating. Any clue?

edit retag flag offensive reopen delete

The question has been closed for the following reason "duplicate question" by Mohjive
close date 2017-09-20 11:27:48.229425

Comments

1

Yeah, it came with 2.1.1 but it seems to be one of the issues that Jolla can't reproduce. Somebody reported it on the release notes post, but it's a good idea to make a dedicated post. What's weird is that if I look at the Wifi details just before connecting, I see that the correct key is present, but when I connect, it asks for it anyway.

Sthocs ( 2017-09-19 14:28:42 +0200 )edit

It only seems to forget Wifi passwords/settings added after the update to 2.1.1 for me. I added UPC Wi-free here in Switzerland, which is WPA-EAP. It did work but next time I wanted to connect, the settings were gone.

Venty ( 2017-09-19 15:42:07 +0200 )edit

Maybe this is related to this problem: I have a static WLAN configuration. There is no DHCP server, so I enter IP address of WLAN interface, Gateway and DNS manually. From time to time the settings disapear or get replaced. Before 2.1.1 it happend regularely, that the DNS server IPv4 address got replaced by an IPv6 address.I have a local IPv6 LAN with an router advertiser.

Since a few weeks the behaviour changed: Now the default route doesn't get installed when the phone changes from mobile to WLAN.

To me that seems that there is something wrong with the daemons accessing the stored configuration. Unfortunately that is all close source, so I have zero motivation to investigate this by myself.

ibins ( 2017-09-19 19:09:37 +0200 )edit

I had this also but only after a rooted dbus send command to switch off the power from Wifi. (it was for the App Situations). Maybe you also switch off the Wifi with commands? After the Update to 2.1.1.26 the bluetooth and wifi needs root for switch off from other apps.

Ralf ( 2017-09-19 23:11:45 +0200 )edit