Ask / Submit
0

pkcon could not find voicecall-ui-jolla

asked 2017-09-20 13:47:24 +0200

ln2v gravatar image

updated 2017-09-21 10:31:58 +0200

I've been having mic troubles during calls on my Jolla phone, and wanted to try a reinstall of the voicecall-ui-jolla, as suggested here: https://together.jolla.com/question/75840/microphone-not-working-during-phone-calls/

[nemo@Sailfish .config]$ pkcon install voicecall-ui-jolla
[...]                                                                                                               
Resolving dependencies                                                                                                         
Fatal error: voicecall-ui-jolla-0.10.1.1-10.76.1.jolla.armv7hl requires voicecall-ui-jolla-settings = 0.10.1.1, but this requirement cannot be provided

So I tried to install settings separately:

[nemo@Sailfish .config]$ pkcon install voicecall-ui-jolla-settings
[...]                                                                                         
Resolving dependencies                                                                                                         
Fatal error: voicecall-ui-jolla-0.10.9.1-10.79.2.jolla.armv7hl requires voicecall-ui-jolla-settings = 0.10.9.1, but this requirement cannot be provided

Note the difference in version numbers.

A search for voicecall packages revealed:

Installed       voicecall-ui-jolla-0.10.9.1-10.79.2.jolla.armv7hl       Jolla Phone application
Available       voicecall-ui-jolla-0.10.1.1-10.76.1.jolla.armv7hl       Jolla Phone application
Installed       voicecall-ui-jolla-settings-0.10.9.1-10.79.2.jolla.armv7hl      Setting page for jolla-voicecall
Available       voicecall-ui-jolla-settings-0.10.1.1-10.76.1.jolla.armv7hl      Setting page for jolla-voicecall

Then I thought, maybe I should uninstall it first.

[root@Sailfish .config]# pkcon uninstall voicecall-ui-jolla
[...]
The following packages have to be removed:
 patterns-sailfish-cellular-apps-0.9.5.1-10.5.1.jolla.noarch    Sailfish Cellular Applications
 voicecall-ui-jolla-0.10.9.1-10.79.2.jolla.armv7hl      Jolla Phone application
Proceed with changes? [N/y] y

Big mistake, as it turns out. I tried the install again, this time as root, got the same error message again, with the old versions:

[root@Sailfish .config]# pkcon install voicecall-ui-jolla
Installing                                                                                                                     
Waiting in queue                                                                                                               
Starting                                                                                                                        
Refreshing software list                                                                                                       
Querying                                                                                                                       
Resolving dependencies                                                                                                         
Fatal error: voicecall-ui-jolla-0.10.1.1-10.76.1.jolla.armv7hl requires voicecall-ui-jolla-settings = 0.10.1.1, but this requirement cannot be provided

I searched for packages again, and now the package/version I just deinstalled, doesn't show up anymore in the list. I tried to install both versions of voicecall-ui-jolla (0.10.1 and 0.10.9), but only ever get the error message:

Command failed: This tool could not find any available package: could not find voicecall-ui-jolla...

Any ideas? I'm running Sailfish OS 2.1.1.26 (Jämsänjoki), if that is of any importance. The phone is a Jolla from 2014, so I suppose it's a Jolla 1?

edit retag flag offensive close delete

Comments

Yes, you have a Jolla 1 phone.

Side note: Reading this, I originally was inclined to state, "Do a pkcon refresh, then retry your steps above", but reading the answer below, the metadata apkcon refresh pulls may not be available for SFOS at the moment. So supposedly the only thing to do is to wait for the SailfishOS 2.1.1.26 repository data to come back online.

olf ( 2017-09-21 00:06:59 +0200 )edit

2 Answers

Sort by » oldest newest most voted
4

answered 2017-09-20 13:58:57 +0200

daywalker gravatar image

updated 2017-09-20 14:04:14 +0200

see here: https://together.jolla.com/question/164349/release-notes-211-jamsanjoki/

  • 2017-08-29: 2.1.1.26 Released to all. [Roll out ceased on Aug 31 for now due to few problem cases with the security code. We are investigating the issue.]

that means if you have already installed it -> repositories are not available for this release atm

edit flag offensive delete publish link more

Comments

F...., ok, that answers my question, thank you! What do I do now, return to previous version? Or get dev repositories?

ln2v ( 2017-09-20 14:01:35 +0200 )edit

can't help you there, i am also waiting because i can't install applications (openrepos) that have dependencies on sfos files

maybe do a backup and a factory reset...

daywalker ( 2017-09-20 14:05:34 +0200 )edit
1

@ln2v, you have no option really but rollback to previous release... :(

juiceme ( 2017-09-20 15:28:27 +0200 )edit

Thank you @juiceme. I tried that, but the install stopped at 75%, the phone seems dead.

[75 %] [Install] jolla-developer-mode 0.3.26-10.27.4.jolla: [100 %]

After taking out the battery, I could start it in so far as it would show the Jolla logo, but then go dead again.

ln2v ( 2017-09-20 16:35:39 +0200 )edit
1

Sounds like a Factory Reset is inevitable now, unfortunately.

For more information on the Factory Reset, see:

https://jolla.zendesk.com/hc/en-us/articles/204709607-Jolla-Phone-How-to-use-Recovery-Mode/

https://jolla.zendesk.com/hc/en-us/articles/201890427-How-do-I-reset-the-phone-to-factory-settings-/

olf ( 2017-09-21 00:16:34 +0200 )edit
0

answered 2017-09-21 20:33:01 +0200

coderus gravatar image
 pkcon refresh
edit flag offensive delete publish link more

Comments

pkcon refresh is still not working, I get: Failed to contact PackageKit: Could not connect: Connection refused, even tho I am able to ping stuff on the internet. Further ideas?

ln2v ( 2017-09-22 00:07:07 +0200 )edit
Login/Signup to Answer

Question tools

Follow
1 follower

Stats

Asked: 2017-09-20 13:47:24 +0200

Seen: 341 times

Last updated: Sep 21 '17