We have moved to a new Sailfish OS Forum. Please start new discussions there.

Tracker not tracking properly

asked 2017-09-21 00:41:02 +0300

Federico gravatar image

updated 2017-10-12 01:05:47 +0300

Recently I have run into some tracker issues. I have found a solution, and I am documenting it here in an answer for other users.


Images missing from the gallery or in wrong order; music files missing from the media player; wrong metadata (image size, duration...). Music player crashes, maybe.

edit retag flag offensive close delete

1 Answer

Sort by » oldest newest most voted

answered 2017-09-21 00:42:36 +0300

Federico gravatar image

updated 2017-10-12 01:07:29 +0300

How to check if this is the problem

Run ps aux | grep -v grep | grep tracker-extract from a terminal. On a working system, you should see a line of text that shows that the process /usr/libexec/tracker-extract is running. If you see nothing instead, it is a confirmation that this is the problem that affects you.


tracker-extract, the process responsible for extracting metadata from audio and image files, choked on some malformed files and crashed.


Run manually /usr/libexec/tracker-extract -v 3. This runs the metadata extractor with debugging output enabled. From there you can catch errors: in my case, a few files were causing a "Floating Point Exception". When I removed these files and restarted the phone, the indexing worked again.

edit flag offensive delete publish link more


You should contact @abranson and provide the files so issue can be fixed. Can you upload those files somewhere?

Damien Caliste ( 2017-10-12 08:38:29 +0300 )edit

Corrected the problem for me. Deleted the culprit file (wasn't listening to this song anyway!). Thanks!

lainwir3d ( 2017-10-12 18:58:40 +0300 )edit

I had a similar issue with the tracker not finding all music files. This solution worked. In my case, all the problem files were .m4a. Is this a bug with the tracker, or a common problem with .m4a files?

elaurin ( 2017-10-19 04:55:05 +0300 )edit

I have uploaded such file to Google Drive. https://drive.google.com/open?id=1RQw7vph0WsM7NTOe-h3wHYTDrHRBQzxK Damien, do you know how to contact @abranson ? When running the command above it also gives me me Floating Point Exception error.

dedrozeba ( 2017-11-07 15:47:04 +0300 )edit

@dedrozeba, I've pinged him on IRC (freenode channel #sailfishos if you want to give a look). Let him have time to answer. I misspell his pseudo on TJC, he is @Andy Branson.

Thank you very much for taking time to provide faulty files, that's great!

Damien Caliste ( 2017-11-07 16:03:58 +0300 )edit
Login/Signup to Answer

Question tools



Asked: 2017-09-21 00:41:02 +0300

Seen: 618 times

Last updated: Oct 12 '17