Ask / Submit
5

Android (at least WhatsApp) losing network connection after ~10min

asked 2017-10-09 23:48:29 +0300

linux inside gravatar image

updated 2017-10-20 19:45:46 +0300

For about a week now I've had this same issue that I had when I first bought my jolla (the original one). It seems that Whatsapp will lose network connection (wlan at least, haven't used much mobile) in about 10 minutes of sleep (=screen locked) no matter what. I won't be receiving messages nor can I send messages before re-enabling wlan. There are multiple similar problems reported here, but none of the solutions I tried worked for me. I have basically tried updating/reinstalling both whatsapp and alien dalvik with and without rebooting the device many times throughout the process. I checked using android terminal to see if dns addresses are the same as in sailfish settings. Sailfish mail app updates mail with no problem but at the same time whatsapp won't. So is there possible solutions? Can I somehow reset all the network settings using terminal because I'm actually also having trouble connecting to an eduroam network? And I'm not 100% certain but I think the latest update 2.1.2.3 did not cause this issue.

EDIT 2017-10-10: I should maybe add that lately I haven't seen the "connection established" (my own translation from Finnish "Yhteys muodostettu") notification in the upper left corner when the wlan or mobile gets connected. Is this because of an update or some setting or could it be related to the problem?¨

EDIT 2017-10-20: I've done some testing and it seems that the problem is not present with mobile data connection. So is there a way to reset wlan settings? And is it ok that there is no notifications when the internet connection is first established (as I explained earlier)?

edit retag flag offensive close delete

Comments

1

I experience the same issue. but I'm still in testing my router. but my problem is more temporar. the connection comes and goes. but it's not only a problem of the Android apps. also native apps and even the browser have the same problem

Dreej ( 2017-10-10 12:15:39 +0300 )edit

I have that problem too -- it's always been like that, it's not a recent thing. You can upvote https://together.jolla.com/question/122636/bug-android-messaging-whatsapp-messages-arrive-late/ .

Federico ( 2017-10-20 21:28:07 +0300 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2017-10-20 21:18:34 +0300

sc19 gravatar image

have you tried installing sailfish utilities from the jolla store and restarting network services. works for me

edit flag offensive delete publish link more

Comments

This does not really solve the problem -- it's just a poor workaround.

Federico ( 2017-10-21 18:21:00 +0300 )edit
Login/Signup to Answer

Question tools

Follow
2 followers

Stats

Asked: 2017-10-09 23:48:29 +0300

Seen: 590 times

Last updated: Oct 20 '17