calendar stuck in 'none'

asked 2017-10-10 15:53:14 +0300

danfin gravatar image

updated 2017-10-10 18:00:24 +0300

since last update 2.1.2.3 my lovely Sailfish Calendar is stuck in 'none' as calendar setting which means every entry I do on my phone goes to Nirvana at next sync (with Google, sorry). Even if I select a specific, existing calendar for my event, the event will be sent to Nirvana all the same. Everything else, especially syncing, works fine --- but when trying to add a new event, it will default to the 'none' calendar whatever settings I choose. Any hints on how to get rid of that silly default calendar is 'none' calendar and any events set to other calendars will be converted to events belonging to 'none' ? It's really annoying, as, from time to time, I'd like to create events on my phone, and NOT on my android one.

edit retag flag offensive close delete

Comments

Uninstall Calendar and reinstall.

Edz ( 2017-10-10 17:45:24 +0300 )edit
1

I have no idea why it is like that, but you can investigate a bit:

  • Check first what are the status of your calendars in the mkcal database with devel-su -p sqlite3 ~/.local/share/system/privileged/Calendar/mkcal/db "select Name, Flags from Calendars;". It should list the calendars and give the flags for them. Flags definitions are given in mer-core/mkcal. The read only bit should be zero and the visible one should be 1.
  • Next, if status are fine, run the calendar in a terminal and look at the possible error messages.
Damien Caliste ( 2017-10-10 17:59:25 +0300 )edit

Uninstall, restart, reinstall does not change anything.

danfin ( 2017-10-11 10:37:15 +0300 )edit