Ask / Submit
43

User reports - Sailfish X

asked 2017-10-11 20:49:06 +0300

h.berd gravatar image

updated 2017-12-18 00:21:26 +0300

Please share your overall experience in this thread. I would love to hear how much you like or dislike Sailfish X.

For Example:

How is the performance in general. Is there a significant difference to Jolla C?

How is your experience with bluetooth connection still in beta?

How much time is needed to flash the phone?

Is the camera working fast? Can you post some pictures to let us see the quality ?

Many thanks in advance and all the best!

edit retag flag offensive close delete

Comments

6

Sample pictures from the camera would indeed be nice!

TomC ( 2017-10-11 21:32:23 +0300 )edit
11

...

How is the performance in general. Is there a significant difference to Jolla C?

Not very much to feel, but the scrolling is smoother

How is your experience with bluetooth connection still in beta?

BT seems fine

How much time is needed to flash the phone?

I needed about 30 min., but I think it is way too hard for many users. If nobody comes up with flashed phones, this will not get an successor. It is complicated, too much different steps...

Is the camera working fast? Can you post some pictures to let us see the quality ?

Is working, faster and the results are better than in Jolla1 or JollaC

poddl ( 2017-10-13 00:48:50 +0300 )edit
43

Something that nobody mentioned yet...

The colour notification LED is back!!!!

Giacomo Di Giacomo ( 2017-10-13 15:25:17 +0300 )edit
9

Yay! I love the colour notification LED :)

Beethoven ( 2017-10-13 16:30:22 +0300 )edit
11

Unbelievable, how simple things, like colour notification LED, can make people so happy. And how these simple things widely ignored in industry.

nlsn ( 2017-10-16 13:19:16 +0300 )edit

48 Answers

Sort by » oldest newest most voted
2

answered 2017-11-27 08:35:03 +0300

danfin gravatar image

It's a nice phone, but not that much different from a Jolla C. Very bright screen. Google sync seems not to be working on 2.1.3.5 nor 2.1.3.7 For now, I am back to Jolla C / Intex Aquafish, where it works fine.

edit flag offensive delete publish link more

Comments

1

You are kidding, right?

Giacomo Di Giacomo ( 2017-11-27 12:12:45 +0300 )edit
1

I'm back to N9 - my wife took the Aquafish - besides sync over bluetooth is not working in any Sailfish X (only contacts to some limited extent). Sailfish X is even worse - and for various reasons, people rate Sailfish X as unusable - my show stopper is HFT car audio, because of bluez5 and no audio gateway profile - spent hours finding out why.

Regarding difference between Jolla C and Sailfish X - I guess OP means not the technical parameters - and I also mean not the technical parameters. Hardware is nice, but at the end not much benefit - just spent about 350€ and it lays around unused. I hope Jolla heard the call and will respond, though not very promising what they said so far.

No kidding! It's sad!

regards

deloptes ( 2017-11-27 12:28:40 +0300 )edit
2

answered 2018-01-08 17:42:52 +0300

Stormy gravatar image

Pro:

  • The Xperia runs for two days with one battery charge
  • The Xperia boots very fast.
  • The operation of Sailfish OS is fast and good.

Contra:

  • Installation: Installing Sailfish OS on the Sony Xperia is very boring issue
  • Camera: The camera only delivers acceptable images if there is sufficient light. It is not suitable for indoor use at the moment
  • Browser: The browser is very, very slow.
  • Email: The Sailfish EMailer is not recommended.
  • Phone: I have to restart the Sony Xperia before every phone call.

Jolla has with Sailfish OS a functional mobile phone operating system, but the basic applications such as telephoning, browser, Email and camera are poorly implemented. In its current form, I hardly like to take the Xperia out of my pocket.

edit flag offensive delete publish link more

Comments

@ Contras out of curiosity, do you know why you should restart the phone before each phone call? I have not experienced this - the other two are downsides I agree. However I did not test sending of e-mails, I created several e-mail profiles for different mailboxes and receiving and reading works perfect. What I have not tested is sending mails. Can you share your experience and why it is not recommended. I tested phone calls and both works perfect - can you share experience and why you have to reboot. Browser: I agree - installed chrome and firefox from the store.

regards

deloptes ( 2018-01-09 01:31:13 +0300 )edit

Are other browsers (for instance, Firefox in Android) also slow? Just to understand if it's a network issue or it's just the builtin browser.

Federico ( 2018-01-09 14:43:52 +0300 )edit

@Federico - I guess you are asking OP, but I answer from my perspective in the hope it will be useful as well. I installed firefox and chrome only because displaying pages is much better - not because it was slow. In theory android apps should have some overhead compared to the native browser, however I rearly noticed such lags. (and I have really slow connection 8Mbit ADSL)

deloptes ( 2018-01-09 16:00:52 +0300 )edit
1

answered 2017-10-15 03:05:58 +0300

ttommila gravatar image

Hi everybody, I need some help (again...):

I try to unlock the boot loader of my X to install Saifish X. It took me already some hours to update the phone (in many steps...would be too nice if the phone would install the newest Firmware at once...) and now some more hours trying to get the boot loader unlocked...(in total at leat 5-6 hours...). As you can imagine: I am not a pro :)

I tried and double checked everything but I think I can't update the "android_winusb.inf" driver (using Windows 10, is this a Problem?). I replaced the original "android_winusb.inf" file with the downloaded one as asked in the sony instructions. When opening the command window and entering the lines asked (on the Sony site) I get only a reply "wating for device". When chosing the "S1Boot Fastboot" device in the device settings I can't update the driver ("there was a problem with Windows installing the driver" - or something similar, I have my Windows in german language).

On the phone I have developer mode enabled and also - hopefully all - the settings asked. The instructions from Sony don't ask to update the driver via device settings - replacing the "android_winusb.inf" should be enough? I just googled some other instructions but they, as written abvoe, don't work neighter for some reason...

What am I doing wrong? Thanks for any help! Would be nice to get a replacement for my almost 4 years old Jolla1 (first ones)... BR, tt

edit flag offensive delete publish link more

Comments

I made a same mistake when updating driver on win7. Follow the jolla instruction to " letter" the important point is to go to " have a disk" point wia selecting manufacturer and device type from list and then " have a disk" whe you can select the file directly. If just trying to do normaly updating driver and pointing directory it will not find the driver " aaarrgh" although it is there.

jpjolla ( 2017-10-15 09:35:56 +0300 )edit

thanks jpjolla! I could find the list. What kind of device is now in question? I can't find Sony in the first list popping up.

ttommila ( 2017-10-15 11:07:41 +0300 )edit

...now I made it, I had to disable "driver signature enforcement". Let's see if I am able to put sailfish on the phone now :)

ttommila ( 2017-10-15 11:27:42 +0300 )edit

The only thing i had to install was that freaking driver which was pretty straight with the instructions. I did not use emma or the sdk, all worked fine (with win 7). If it helps we can try to get it running (also in German) but i don't consider me as a pro, too :) but maybe that helps then :D

NuklearFart ( 2017-10-18 23:42:26 +0300 )edit

It was the "driver signature enforcement" that I had to disable on win10. I think maybe others had this same problem because I couldn't find anything about this in the instructions from Sony or Jolla.

ttommila ( 2017-10-22 20:36:11 +0300 )edit
1

answered 2017-10-18 11:00:40 +0300

mrtrm gravatar image
  • Trying to reach from my linux box through ssh gives me error: ssh: connect to host 192.xxx.xxx.xx port 22: Connection refused - worked well in my C-ified Aquafish
  • Bluetooth audio connection with JBL speaker and Cambridge audio speaker stutters easily (when browsing the web for instance) - worked well in my C-ified Aquafish
  • Tethering my mobile network to my laptop doesn't work (I need that when working in places where there's no Wifi) - worked well in my C-ified Aquafish
  • Miss the double tap to wake up the screen.
edit flag offensive delete publish link more

Comments

..

Trying to reach from my linux box through ssh gives me error: ssh: connect to host 192.xxx.xxx.xx port 22: Connection refused - worked well in my C-ified Aquafish

Is working here. On connection start make sure you're display is on.

Bluetooth audio connection with JBL speaker and Cambridge audio speaker stutters easily (when browsing the web for instance) - worked well in my C-ified Aquafish

Same here

Tethering my mobile network to my laptop doesn't work (I need that when working in places where there's no Wifi) - worked well in my C-ified Aquafish

solution for tethering

Miss the double tap to wake up the screen.

Serach the forum, there is a solution for it.

poddl ( 2017-10-18 12:39:24 +0300 )edit
1

@poddl: thx a lot! 3 of 4 of my major issues solved!

mrtrm ( 2017-10-19 10:19:36 +0300 )edit

works very well for me. i had to set a fixed address, the password and then i could login as nemo. just like with my jolla 1 before. to get to the device with the kde file manager dolphin i had to delete the host key first that had appeared in my known_hosts. then sftp access in the file manager worked, too.

jabgoe ( 2017-10-20 16:01:39 +0300 )edit
1

answered 2017-10-30 09:06:55 +0300

Marius gravatar image

For me flashing was a bit confusing, but it worked well at the end. Xpeia is of course much faster than Jolla 1, however I experience strange slowdowns with email application. Suddenly I have to wait for email to appear (already downloaded) or there is a significant lag when changing the mailboxes. I also have problem setting up synchronization with Exchange account. I have two of them and the first one worked well, while the second one - never managed to succeed (however there is a trick described on this forum about killing the process in the middle - I have to try it). Other strange thing is that after reboot Xperia is not asking for the PIN number of the SIM card. Is that normal?

edit flag offensive delete publish link more

Comments

1

E-mail app: It's a problem of showing HTML content.

wosrediinanatour ( 2017-10-30 10:10:47 +0300 )edit

I cannot add exchange account at all :( (on premise Exchange 2017) - the add account function get stuck after inputting the server parameters/values in "creating account"

ehakkarainen ( 2017-10-30 18:56:43 +0300 )edit

the exchange account can be added, just try again and again, thats what i did after the third time it was a charm.

XFish ( 2017-10-30 19:03:54 +0300 )edit
1

answered 2017-11-02 16:58:43 +0300

L_A_G gravatar image

My experience as someone who had a Jolla phone, switched to an Android phone and now came back are overall pretty positive. A short summary of my experiences so far, using the Nexus 5 and Jolla phone as reference, formated as bullet points for maximum readability:

Positive:

  • Very nicely built hardware that feels sturdy in your hand
  • Superb battery life (in my use the Nexus 5 I replaced it with lasted about a day on a brand new battery while this thing lasts for 2 days)
  • Gorgeous screen
  • Seemingly durable (dropped it on a wood floor and it didn't even leave a mark, not the most demanding height however)
  • Very good android app compatibility
  • Still has a MicroSD card slot when flagship android devices dropped it years ago
  • SailfishOS is still as powerful and smooth as it always was
  • Still none of the spying built into Android, iOS and WP

Negative:

  • The self-flash process, while nothing close to a complete showstopper, was none the less a bit annoying
  • Battery replacement, while possible, is an unnecessary pain in the you-know-what with the way you need a suction cup and a heat gun to get the back cover off and glue strips to get it back on again
  • No double tap to wake (found myself trying to use it constantly for the first week)

Mixed:

  • Native app support is as bad as always, but android support is still good and improved compared to the Jolla phone
  • While a huge upgrade from the original, the camera still has some minor focus issues
  • The media player is as good as it ever was, but still annoyingly needs to indexes all of your music from the nothing every single time you start it up (one in the N9 didn't need to do this despite being very similar)
  • Browser is as awful as it always was, thankfully you're spoiled for good choices in the android apps

I do have to say that I was initially a bit skeptical about Jolla's choice of hardware, but having used mine since the weekend after it came out, I do have to say that they definitely made a very wise choice. Let's hope that with licensing to third parties going Jolla can hire more people to get things like the native app store properly sorted out to attract more developers and do something about that dreadful default browser.

edit flag offensive delete publish link more

Comments

There is a workaround to enable double tap to weak up, just search for it, its so comfortable.

NuklearFart ( 2017-11-05 00:39:18 +0300 )edit
1

@L_A_G the music reindexing is indeed weird and have noticed it every time the app is restarted

XFish ( 2017-11-05 05:29:59 +0300 )edit

The double tap workaround is buggy after having used it for months it causes issues during phone unlock so not worth the risk until it bug free and flawless.

DarkTuring ( 2017-12-19 17:07:25 +0300 )edit

Hi, Have you tried this?

mcetool --set-doubletap-wakeup=proximity
deloptes ( 2017-12-19 23:02:07 +0300 )edit
1

answered 2017-11-09 23:42:36 +0300

sfinnie gravatar image

Successfully completed, although a few queasy moments on the way (see below). Been running for a few days now, and all good so far. Immediate impressions:

  1. It looks gorgeous. Yes, beauty in the eye of the beholder and all that. But compared to the gaudy default Android options, the Sailfish theme is beautiful. I've already had several "ooooh, what's that?" moments.
  2. It's functionally stable. Haven't used bluetooth yet so can't comment on that. But everything else is solid and responsive
  3. Performance is notably better than my J1. It should be given the difference in hardware specs, but that doesn't always follow. Good to see it does here. Browser perhaps most noticeable (understandably)
  4. The blue notification light. Hurrah :)

The wrinkles:

  1. The installation instructions are a little ambiguous on where to put the sony binary. It says "paste it to the same directory where you extracted the Sailfish OS .zip file ". However: extracting the Sailfish image creates a new sub-directory Sailfish-OS-<version>. So: should the Sony binary go into the folder containing the sailfish tar file, or the sub-directory that extraction creates? (answer is the latter btw)
  2. Installation failed from my laptop (elementaryOS linux). Attempting to flash always aborted with error FAILED (status read failed (Cannot send after transport endpoint shutdown)). Happened at different places in the process. Tried on desktop (linux mint) & worked first time.
  3. First boot took a loooong time. I'd resigned myself to it having hung and was about to re-flash. It burst into life while I was preparing. Would estimate boot took 3-4 minutes, maybe more.
  4. Attempting to restore backup from my J1 failed. Froze the phone & needed restart. Still haven't resolved this. Backup quite large but not excessively so (2.3GiB). Have copied to desktop & will manually prune before trying again.

Otherwise really pretty smooth, good job guys :)

edit flag offensive delete publish link more
0

answered 2017-12-19 12:27:57 +0300

libbresse gravatar image

updated 2017-12-19 12:32:29 +0300

Works quite good.

No good working youtube apps. Sometimes youtube freezes in my browser, can't get it to play again. Have to reboot phone to start playing again.

Freezes streams for a while when going in and out from wifi zones.

Sharing wifi wont work for me even after following the guide mentioned above.

Missing snapchat app.

Missing brave browser Can't find anywhere to change alarm volume to my alarm clock ?

edit flag offensive delete publish link more

Comments

1

The alarm clock volume issue can be fixed with https://openrepos.net/content/slava/clock-settings

tmy ( 2017-12-19 14:13:48 +0300 )edit

Tried it, still, could not change alarm volume

libbresse ( 2017-12-19 14:51:27 +0300 )edit

you have to reboot after installation - or restart some service, but I don't know which

deloptes ( 2017-12-19 15:35:26 +0300 )edit

Tried reboot, still no volume adjust slider

libbresse ( 2017-12-19 16:15:49 +0300 )edit
1

Settings-applications-clock. You can adjust snooze and volume

LumoUkko ( 2017-12-19 20:53:33 +0300 )edit
Login/Signup to Answer

Question tools

Follow
24 followers

Stats

Asked: 2017-10-11 20:49:06 +0300

Seen: 22,417 times

Last updated: Jan 08 '18