Ask / Submit
83

[Howto] Enable "double tap to lockscreen" gesture on SailfishX

asked 2017-10-12 13:41:59 +0300

evo3de gravatar image

updated 2017-10-21 01:02:08 +0300

objectifnul gravatar image

Open Terminal

devel-su
pkcon install mce-tools
mcetool --set-doubletap-mode=show-unlock-screen
mcetool -i disabled
mcetool -z proximity

Have fun ;-)

rem: for undo check the comments

edit retag flag offensive close delete

Comments

4

Does anyone know if this have impact on battery life?

Louis ( 2017-10-12 13:56:54 +0300 )edit
8

@Louis - enable it and you tell us your findings :)

Edz ( 2017-10-12 14:07:12 +0300 )edit
1

slight correction: first mcetool command should be "mcetool --set-doubletap-mode=show-unlock-screen"

JPS ( 2017-10-12 14:15:11 +0300 )edit
3

Ahhh thanks, worked like a charme.

I have to say, battery live seems to be worse then with the Android ROM from Sony already. But will have an eye if it's getting even worse.

duque ( 2017-10-12 14:37:46 +0300 )edit

Works! Great! Thank you!

SagaciousT ( 2017-10-12 15:37:48 +0300 )edit

5 Answers

Sort by » oldest newest most voted
12

answered 2017-10-18 11:17:24 +0300

ghling gravatar image

I'm not sure if this is related to tap-to-wake/unlock, but I sometimes experience the issue on my Xperia X with enabled tap-to-wake that my screen is completely unresponsive after wake up. It won't recognize any touch, I have to turn it of and then on again to be able to use it. Does anyone have similar issues?

edit flag offensive delete publish link more

Comments

3

The same for me.

Luca ( 2017-10-18 11:47:13 +0300 )edit
1

i also recognized this, but only once and after i washed the dishes.

breiti_oi ( 2017-10-18 11:48:50 +0300 )edit
1

me not, no freeze after wakeup

pawel ( 2017-10-18 13:15:49 +0300 )edit
1

The same for me to

scegliau ( 2017-10-18 16:02:01 +0300 )edit
1

i recognized this behavier only in combination with active LPM

evo3de ( 2017-10-18 16:13:20 +0300 )edit
7

answered 2017-10-13 23:32:41 +0300

Mariusmssj gravatar image

I wonder how much worse is the battery life after enabling it?

edit flag offensive delete publish link more

Comments

I think, however I have liked double-tap with N9 and Jolla 1&C, I will pass this in the beginging sofar. I have so bad memories with the high power consumption of Jolla C. However, I do miss double-tapping. In fact I am trying to that with Sony Sailfish X all the time until I note that it have not any influnce ...

N9Sailfish ( 2017-10-15 19:31:37 +0300 )edit
7

I tested consumption during the night(8hours). There is no difference for Jolla_C, but for Xperia_X... Consumed power WITHOUT doubletap is 31.25mW(2...3% during the night) and WITH doubletap is 63.75mW(6...7% during the night). 3G=on, Wi-Fi=BT=Internet=off.

Oleg ( 2017-10-16 10:34:40 +0300 )edit

Thank you. This confirms that I will pass sofar.

N9Sailfish ( 2017-10-16 17:07:03 +0300 )edit
1

I wonder if there will be an 'official' support for this with no or very little effect on battery life, at some point.

Ingvix ( 2017-10-19 09:51:22 +0300 )edit
1

For me this has had extremely little effect on battery life. Something like 1 to 2 percent in 12 hours.

Manatus ( 2017-10-19 14:35:06 +0300 )edit
7

answered 2017-10-18 22:43:52 +0300

MystIsland gravatar image

In Sailfish X Build and Flash wiki, this command is given:

Double-tap to wake is deactivated. Activate it and help testing in various scenarios by:

mcetool --set-doubletap-wakeup=proximity

I used that one and at least so far the battery consumption looks still very good (phone was charged to 100%, unplugged and now after about 1-1,5 hours it's still at 100%).

How does the commands presented in this thread differ over the one quoted above?

edit flag offensive delete publish link more

Comments

no expert but if you read the comments here, than you have.more options. react allwys or only when proximity sensor allows it. go to lockscreen or somewhere else ...

the commbds here in hve lso no effect on bttery

pawel ( 2017-10-19 07:04:50 +0300 )edit
5

answered 2017-10-20 22:58:43 +0300

silta gravatar image

updated 2017-10-21 00:53:10 +0300

Thanks @evo3de. But unfortunately it doesn´t work properly if I have enabled low power mode.

During the 5 seconds the clock is shown in lpm mode, double tap does nothing.

If you would like to use low power mode and double tap simultaneously you have to set

mcetool -M show-unlock-screen
mcetool -z proximity
mcetool -i enabled
mcetool -E enabled
edit flag offensive delete publish link more

Comments

Have you faced an unresponsive lockscreen with these settings? At the time when opened with power button the lock screen does to response to any touch gestures. I need to press the button again to turn the screen off and back on to get it working. EDIT: Never mind. I think it's one of patches that's doing it.

Ingvix ( 2017-11-02 11:49:03 +0300 )edit
2

answered 2017-10-13 00:46:23 +0300

Sailor_John_Doe gravatar image

updated 2017-10-13 00:56:41 +0300

Does this actually enable the double-tap wake-up gesture which I badly miss on my Xperia X?

Edit: I just found out that this indeed enables the missing gesture! Thank you much guys, now my Xperia X is perfect!!

edit flag offensive delete publish link more

Comments

6

yes, and if you use this command:

mcetool -M unlock

...you will pass the unlock screen and go direct to the home view.

poddl ( 2017-10-13 00:52:51 +0300 )edit
1

Yes it does based in my testing. how do you undo the command above?

XFish ( 2017-10-13 17:22:55 +0300 )edit
1

I think that command mcetool --set-doubletap-mode=show-unlock-screen disable that -M unlock option (quick tested)

LumoUkko ( 2017-10-15 12:54:00 +0300 )edit
Login/Signup to Answer

Question tools

Follow
34 followers

Stats

Asked: 2017-10-12 13:41:59 +0300

Seen: 5,368 times

Last updated: Oct 21 '17