Ask / Submit
1

SFOS 2.1.3: Duplicate calendars on ActiveSync account

asked 2017-10-12 13:53:00 +0200

tmichel gravatar image

updated 2017-10-12 14:01:49 +0200

jiit gravatar image

Hi,

Using SFOS 2.1.3 on Xperia X.

I have an Office 365 account with an additional calendar in it (for sharing with the family). While the default calendar syncs just fine using Activesync, the additional calendar appers three times in the calendar list.

Does anybody else have this problem?

edit retag flag offensive close delete

Comments

I had this once with 2.1.1 and CalDAV <-> Nextcloud. For me deleting the account and re-initializing it did the job.

cy8aer ( 2017-10-12 14:20:30 +0200 )edit

Also having this problem with Sony Xperia X & Sailfish X. Using Outlook.com for calendar sync. Once I add the Exchange Account on my phone, all calenders that I have ever added on Outlook.com are shown in the list under "Manage Calendars". Even the ones that I have deleted long ago. Deleting and re-adding the Exchange Account does not fix this. Is there any way to clean up these old calendars???

sgleo87 ( 2018-08-16 12:32:25 +0200 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2017-10-12 15:15:23 +0200

Maus gravatar image

updated 2017-10-12 15:17:15 +0200

Jolla ships different ActiveSync client plugins to different devices. The original Jolla Phone ships with the old plugin, which is derived from Nokia code and licensed specifically for the J1 device. Releases for other devices contain the new plugin. Perhaps you didn't experience this bug until using a new plugin.

As @cybaer noted, this calendar duplication has also been found in CalDAV plugins and has been addressed in an unofficial build that is being tested at the moment. Perhaps the bug in the EAS plugin is of the same type and can be fixed as well.

edit flag offensive delete publish link more

Comments

Deleting and re-adding does not work. Also, not the calendar entries are duplicated, but I can see the same calnedar three times under settings->manage calendars.

But it seems Activesync is broken entirely -after the initial sync it does not sync any more, no mails can be sent or recieved. After restarting the device, the maisl come in again but just once. A second synch does nto work.

tmichel ( 2017-10-13 17:50:05 +0200 )edit
Login/Signup to Answer

Question tools

Follow
4 followers

Stats

Asked: 2017-10-12 13:53:00 +0200

Seen: 128 times

Last updated: Oct 12 '17